Cloudera Labs
Provide feedback on Cloudera Labs
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Dependency not satisfied for release CLABS_KAFKA(0.8.2-1.kafka1.1.0.p0.23): CDH (at least 5.2).

Solved Go to solution
Highlighted

Dependency not satisfied for release CLABS_KAFKA(0.8.2-1.kafka1.1.0.p0.23): CDH (at least 5.2).

Explorer

Downloaded the latest Clouder Quickstart VM with CDH 5.3 and installed Kafka using CSD (CLABS_KAFKA-1.1.0.jar ... 0.8.2-1.kafka1.1.0.p0.23).

 

When pressing Activate, I get the error

Dependency not satisfied for release CLABS_KAFKA(0.8.2-1.kafka1.1.0.p0.23): CDH (at least 5.2).

though obviously on CDH 5.3

 

Thanks for your help in advance

Slavo

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Dependency not satisfied for release CLABS_KAFKA(0.8.2-1.kafka1.1.0.p0.23): CDH (at least 5.2).

New Contributor

Hi, the solution is update CDH 5.3x to the new 5.3.3. Than the activation works.

View solution in original post

4 REPLIES 4

Re: Dependency not satisfied for release CLABS_KAFKA(0.8.2-1.kafka1.1.0.p0.23): CDH (at least 5.2).

Contributor

What version of Cloudera Manager are you using?

Highlighted

Re: Dependency not satisfied for release CLABS_KAFKA(0.8.2-1.kafka1.1.0.p0.23): CDH (at least 5.2).

Explorer

It is Cloudera Quickstart VM with CDH5.3, so CM is Cloudera Express 5.3.0.

But I guess the reason is fairly straightforward. Quickstart VM does not seem to support installation using parcels and that contradicts with the statment in the installation notes ( "the CSD can be installed only on parcel-deployed clusters" http://www.cloudera.com/content/cloudera/en/developers/home/cloudera-labs/apache-kafka.html)

Everything worked fine in our test cluster.

Highlighted

Re: Dependency not satisfied for release CLABS_KAFKA(0.8.2-1.kafka1.1.0.p0.23): CDH (at least 5.2).

New Contributor

I run into the same issue. Using CDH 5.3 Quick Start VM and try to install Kafka and got the same error message.  Why Quickstart VM does not support installation using parcels? Did you find any documentation on that?

 

 

Highlighted

Re: Dependency not satisfied for release CLABS_KAFKA(0.8.2-1.kafka1.1.0.p0.23): CDH (at least 5.2).

New Contributor

Hi, the solution is update CDH 5.3x to the new 5.3.3. Than the activation works.

View solution in original post

Don't have an account?
Coming from Hortonworks? Activate your account here