Reply
Highlighted
ash
Explorer
Posts: 7
Registered: ‎09-12-2013

1 host running a mixed version of CDH

Hello,

 

I have 5 VMs with cloudera hadoop installed on it. When I run hadoop version, I get Hadoop 2.0.0-cdh4.4.0 on the VMs. So this means it has the same version of CDH right?

 

Whenever I try adding a new cluster using these VMs using Cloudera manager 4.7.1, I get an error on host inspector

 

1 hosts are reporting with MIXED CDH version

 

Is this the same thing the one I mentioned before? Can anyone suggest me how to fix this?

 

Thanks

Posts: 416
Topics: 51
Kudos: 86
Solutions: 49
Registered: ‎06-26-2013

Re: 1 host running a mixed version of CDH

@ash:

 

I apologize on the delay in response here.  I have moved this thread to the Cloudera Manager board so that the subject matter experts for CM can reply.  In the meantime, can you elaborate on how you installed CDH on the cluster?  Did you just run the CM installer binary and let the wizard deploy CDH4.4.0 to the nodes automatically?  Also, are you using Parcels or RPMs?

 

Setting up a VM cluster is difficult as all nodes must have network connectivity to each other, DNS (and/or /etc/hosts) must be set up such that they can all resolve each other's hostnames/IPs, etc.  Things like iptables need to be disabled so that there are no network blockades to the CM agents communicating back into the CM server.  Have you verified all this?

 

Regards,


Clint

Contributor
Posts: 28
Registered: ‎03-04-2014

Re: 1 host running a mixed version of CDH

It is possible that , any previous installation that are not compleltely removed, is still sitting on the node.

 

try removing the folders ex(/usr/lib/oozie, /etc/oozie) or whichever component the host inspector shows as diff version. and then install through yum ( yum install oozie).

Announcements