Reply
Highlighted
Explorer
Posts: 14
Registered: ‎03-20-2016
Accepted Solution

Cloudera Manager Agent installation - package conflict

I am attempting installation of Cloudera Enterprise 5.6.x on Red Hat Enterprise Linux Server release 6.7 (Santiago).

 

I am following steps described as "installation path b".

 

I have encountered an error installing Cloudera Manager Agent Packages..

 

$ sudo yum install cloudera-manager-agent cloudera-manager-daemons
Loaded plugins: rhnplugin, security
This system is receiving updates from RHN Classic or RHN Satellite.
Setting up Install Process
Package cloudera-manager-daemons-5.6.0-1.cm560.p0.54.el6.x86_64 already installed and latest version
Resolving Dependencies
--> Running transaction check
---> Package cloudera-manager-agent.x86_64 0:5.6.0-1.cm560.p0.54.el6 will be installed
--> Processing Dependency: portmap for package: cloudera-manager-agent-5.6.0-1.cm560.p0.54.el6.x86_64
--> Processing Dependency: fuse for package: cloudera-manager-agent-5.6.0-1.cm560.p0.54.el6.x86_64
--> Processing Dependency: mod_ssl for package: cloudera-manager-agent-5.6.0-1.cm560.p0.54.el6.x86_64
--> Processing Dependency: MySQL-python for package: cloudera-manager-agent-5.6.0-1.cm560.p0.54.el6.x86_64
--> Processing Dependency: httpd for package: cloudera-manager-agent-5.6.0-1.cm560.p0.54.el6.x86_64
--> Processing Dependency: fuse-libs for package: cloudera-manager-agent-5.6.0-1.cm560.p0.54.el6.x86_64
--> Processing Dependency: cyrus-sasl-gssapi for package: cloudera-manager-agent-5.6.0-1.cm560.p0.54.el6.x86_64
--> Processing Dependency: python-psycopg2 for package: cloudera-manager-agent-5.6.0-1.cm560.p0.54.el6.x86_64
--> Processing Dependency: openssl-devel for package: cloudera-manager-agent-5.6.0-1.cm560.p0.54.el6.x86_64
--> Processing Dependency: /lib/lsb/init-functions for package: cloudera-manager-agent-5.6.0-1.cm560.p0.54.el6.x86_64
--> Running transaction check
---> Package MySQL-python.x86_64 0:1.2.3-0.3.c1.1.el6 will be installed
---> Package cyrus-sasl-gssapi.x86_64 0:2.1.23-15.el6_6.2 will be installed
---> Package fuse.x86_64 0:2.8.3-4.el6 will be installed
---> Package fuse-libs.x86_64 0:2.8.3-4.el6 will be installed
---> Package httpd24u.x86_64 0:2.4.18-3.ius.el6.7.z will be installed
--> Processing Dependency: httpd-filesystem = 2.4.18-3.ius.el6.7.z for package: httpd24u-2.4.18-3.ius.el6.7.z.x86_64
--> Processing Dependency: httpd-filesystem = 2.4.18-3.ius.el6.7.z for package: httpd24u-2.4.18-3.ius.el6.7.z.x86_64
--> Processing Dependency: httpd-tools = 2.4.18-3.ius.el6.7.z for package: httpd24u-2.4.18-3.ius.el6.7.z.x86_64
--> Processing Dependency: libnghttp2.so.14()(64bit) for package: httpd24u-2.4.18-3.ius.el6.7.z.x86_64
--> Processing Dependency: libapr15uutil-1.so.0()(64bit) for package: httpd24u-2.4.18-3.ius.el6.7.z.x86_64
--> Processing Dependency: libapr15u-1.so.0()(64bit) for package: httpd24u-2.4.18-3.ius.el6.7.z.x86_64
---> Package mod_ssl.x86_64 1:2.2.15-47.el6_7.3 will be installed
--> Processing Dependency: httpd = 2.2.15-47.el6_7.3 for package: 1:mod_ssl-2.2.15-47.el6_7.3.x86_64
--> Processing Dependency: httpd-mmn = 20051115 for package: 1:mod_ssl-2.2.15-47.el6_7.3.x86_64
---> Package openssl-devel.x86_64 0:1.0.1e-42.el6_7.4 will be installed
--> Processing Dependency: krb5-devel for package: openssl-devel-1.0.1e-42.el6_7.4.x86_64
--> Processing Dependency: zlib-devel for package: openssl-devel-1.0.1e-42.el6_7.4.x86_64
---> Package python-psycopg2.x86_64 0:2.0.14-2.el6 will be installed
--> Processing Dependency: libpq.so.5()(64bit) for package: python-psycopg2-2.0.14-2.el6.x86_64
---> Package redhat-lsb-core.x86_64 0:4.0-7.el6 will be installed
--> Processing Dependency: perl-ExtUtils-MakeMaker for package: redhat-lsb-core-4.0-7.el6.x86_64
--> Processing Dependency: perl-Test-Harness for package: redhat-lsb-core-4.0-7.el6.x86_64
--> Processing Dependency: perl-Test-Simple for package: redhat-lsb-core-4.0-7.el6.x86_64
--> Processing Dependency: perl-CGI for package: redhat-lsb-core-4.0-7.el6.x86_64
--> Processing Dependency: /bin/gettext for package: redhat-lsb-core-4.0-7.el6.x86_64
--> Processing Dependency: /usr/bin/pax for package: redhat-lsb-core-4.0-7.el6.x86_64
--> Processing Dependency: /usr/bin/msgfmt for package: redhat-lsb-core-4.0-7.el6.x86_64
--> Processing Dependency: /usr/bin/patch for package: redhat-lsb-core-4.0-7.el6.x86_64
---> Package rpcbind.x86_64 0:0.2.0-11.el6_7 will be installed
--> Processing Dependency: libgssglue for package: rpcbind-0.2.0-11.el6_7.x86_64
--> Processing Dependency: libtirpc.so.1()(64bit) for package: rpcbind-0.2.0-11.el6_7.x86_64
--> Running transaction check
---> Package apr15u.x86_64 0:1.5.2-1.ius.el6.7.z will be installed
---> Package apr15u-util.x86_64 0:1.5.4-3.ius.el6.7.z will be installed
---> Package gettext.x86_64 0:0.17-18.el6 will be installed
--> Processing Dependency: libgomp.so.1(GOMP_1.0)(64bit) for package: gettext-0.17-18.el6.x86_64
--> Processing Dependency: cvs for package: gettext-0.17-18.el6.x86_64
--> Processing Dependency: libgomp.so.1()(64bit) for package: gettext-0.17-18.el6.x86_64
---> Package httpd.x86_64 0:2.2.15-47.el6_7.3 will be installed
--> Processing Dependency: httpd-tools = 2.2.15-47.el6_7.3 for package: httpd-2.2.15-47.el6_7.3.x86_64
--> Processing Dependency: apr-util-ldap for package: httpd-2.2.15-47.el6_7.3.x86_64
--> Processing Dependency: libaprutil-1.so.0()(64bit) for package: httpd-2.2.15-47.el6_7.3.x86_64
--> Processing Dependency: libapr-1.so.0()(64bit) for package: httpd-2.2.15-47.el6_7.3.x86_64
---> Package httpd24u-filesystem.noarch 0:2.4.18-3.ius.el6.7.z will be installed
---> Package httpd24u-tools.x86_64 0:2.4.18-3.ius.el6.7.z will be installed
---> Package krb5-devel.x86_64 0:1.10.3-42z1.el6_7 will be installed
--> Processing Dependency: libcom_err-devel for package: krb5-devel-1.10.3-42z1.el6_7.x86_64
--> Processing Dependency: keyutils-libs-devel for package: krb5-devel-1.10.3-42z1.el6_7.x86_64
--> Processing Dependency: libselinux-devel for package: krb5-devel-1.10.3-42z1.el6_7.x86_64
---> Package libgssglue.x86_64 0:0.1-11.el6 will be installed
---> Package libnghttp2.x86_64 0:1.6.0-1.el6.1 will be installed
---> Package libtirpc.x86_64 0:0.2.1-10.el6 will be installed
---> Package patch.x86_64 0:2.6-6.el6 will be installed
---> Package pax.x86_64 0:3.4-10.1.el6 will be installed
---> Package perl-CGI.x86_64 0:3.51-141.el6_7.1 will be installed
---> Package perl-ExtUtils-MakeMaker.x86_64 0:6.55-141.el6_7.1 will be installed
--> Processing Dependency: perl-devel for package: perl-ExtUtils-MakeMaker-6.55-141.el6_7.1.x86_64
---> Package perl-Test-Harness.x86_64 0:3.17-141.el6_7.1 will be installed
---> Package perl-Test-Simple.x86_64 0:0.92-141.el6_7.1 will be installed
---> Package postgresql-libs.x86_64 0:8.4.20-5.el6_7 will be installed
---> Package zlib-devel.x86_64 0:1.2.3-29.el6 will be installed
--> Running transaction check
---> Package apr.x86_64 0:1.3.9-5.el6_2 will be installed
---> Package apr-util.x86_64 0:1.3.9-3.el6_0.1 will be installed
---> Package apr-util-ldap.x86_64 0:1.3.9-3.el6_0.1 will be installed
---> Package cvs.x86_64 0:1.11.23-16.el6 will be installed
---> Package httpd-tools.x86_64 0:2.2.15-47.el6_7.3 will be installed
---> Package keyutils-libs-devel.x86_64 0:1.4-5.el6 will be installed
---> Package libcom_err-devel.x86_64 0:1.41.12-22.el6 will be installed
---> Package libgomp.x86_64 0:4.4.7-16.el6 will be installed
---> Package libselinux-devel.x86_64 0:2.0.94-5.8.el6 will be installed
--> Processing Dependency: libsepol-devel >= 2.0.32-1 for package: libselinux-devel-2.0.94-5.8.el6.x86_64
--> Processing Dependency: pkgconfig(libsepol) for package: libselinux-devel-2.0.94-5.8.el6.x86_64
---> Package perl-devel.x86_64 4:5.10.1-141.el6_7.1 will be installed
--> Processing Dependency: gdbm-devel for package: 4:perl-devel-5.10.1-141.el6_7.1.x86_64
--> Processing Dependency: perl(ExtUtils::ParseXS) for package: 4:perl-devel-5.10.1-141.el6_7.1.x86_64
--> Processing Dependency: db4-devel for package: 4:perl-devel-5.10.1-141.el6_7.1.x86_64
--> Processing Dependency: glibc-devel for package: 4:perl-devel-5.10.1-141.el6_7.1.x86_64
--> Running transaction check
---> Package db4-devel.x86_64 0:4.7.25-20.el6_7 will be installed
--> Processing Dependency: db4-cxx = 4.7.25-20.el6_7 for package: db4-devel-4.7.25-20.el6_7.x86_64
--> Processing Dependency: libdb_cxx-4.7.so()(64bit) for package: db4-devel-4.7.25-20.el6_7.x86_64
---> Package gdbm-devel.x86_64 0:1.8.0-38.el6 will be installed
---> Package glibc-devel.x86_64 0:2.12-1.166.el6_7.7 will be installed
--> Processing Dependency: glibc-headers = 2.12-1.166.el6_7.7 for package: glibc-devel-2.12-1.166.el6_7.7.x86_64
--> Processing Dependency: glibc-headers for package: glibc-devel-2.12-1.166.el6_7.7.x86_64
---> Package libsepol-devel.x86_64 0:2.0.41-4.el6 will be installed
---> Package perl-ExtUtils-ParseXS.x86_64 1:2.2003.0-141.el6_7.1 will be installed
--> Running transaction check
---> Package db4-cxx.x86_64 0:4.7.25-20.el6_7 will be installed
---> Package glibc-headers.x86_64 0:2.12-1.166.el6_7.7 will be installed
--> Processing Dependency: kernel-headers >= 2.2.1 for package: glibc-headers-2.12-1.166.el6_7.7.x86_64
--> Processing Dependency: kernel-headers for package: glibc-headers-2.12-1.166.el6_7.7.x86_64
--> Processing Conflict: httpd24u-2.4.18-3.ius.el6.7.z.x86_64 conflicts httpd < 2.4.18
--> Processing Conflict: httpd24u-tools-2.4.18-3.ius.el6.7.z.x86_64 conflicts httpd-tools < 2.4.18
--> Finished Dependency Resolution
Error: httpd24u-tools conflicts with httpd-tools-2.2.15-47.el6_7.3.x86_64
Error: httpd24u conflicts with httpd-2.2.15-47.el6_7.3.x86_64
Error: Package: glibc-headers-2.12-1.166.el6_7.7.x86_64 (rhel-x86_64-server-6.7.z)
           Requires: kernel-headers >= 2.2.1
Error: Package: glibc-headers-2.12-1.166.el6_7.7.x86_64 (rhel-x86_64-server-6.7.z)
           Requires: kernel-headers
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

 

Would appreciate any suggestions on how to resolve.

 

Thank you

 

Cloudera Employee
Posts: 276
Registered: ‎07-08-2013

Re: Cloudera Manager Agent installation - package conflict

[ Edited ]

Hi Romulus,

 

OS level dependencies causing the conflict, since you have Red Hat Enterprise Linux Server you should file a ticket with RHEL to troubleshoot the issue. At first glance it looks like your IUS repo is causing the conflict.

 

Hope this helps.

Explorer
Posts: 14
Registered: ‎03-20-2016

Re: Cloudera Manager Agent installation - package conflict

I appreciate the prompt reply. Good suggestion.

Thanks!

Explorer
Posts: 14
Registered: ‎03-20-2016

Re: Cloudera Manager Agent installation - package conflict

Problem resolved by running..

 

sudo yum --disablerepo=rackspace-rhel-x86_64-server-6.7.z-ius --disableexcludes=all install cloudera-manager-agent cloudera-manager-daemons

New Contributor
Posts: 1
Registered: ‎08-17-2017

Re: Cloudera Manager Agent installation - package conflict

Error: Package: cloudera-manager-agent-5.12.0-1.cm5120.p0.120.el7.x86_64 (cloudera-manager)
Requires: httpd
Error: Package: cloudera-manager-agent-5.12.0-1.cm5120.p0.120.el7.x86_64 (cloudera-manager)
Requires: MySQL-python
Error: Package: cloudera-manager-agent-5.12.0-1.cm5120.p0.120.el7.x86_64 (cloudera-manager)
Requires: mod_ssl

am getting this error even after setup of proxy everything
Announcements