Reply
Explorer
Posts: 9
Registered: ‎05-13-2019

Enabling auto-TLS, failed to receive heartbeat from agent.

Install CDH step by step followed the document.

 

Enabled auto-TLS, after all agents are installed, get error message:

 

 Installation failed. Failed to receive heartbeat from agent.
Ensure that the host's hostname is configured properly.
Ensure that port 7182 is accessible on the Cloudera Manager Server (check firewall rules).
Ensure that ports 9000 and 9001 are not in use on the host being added.
Check agent logs in /var/log/cloudera-scm-agent/ on the host being added. (Some of the logs can be found in the installation details).
If Use TLS Encryption for Agents is enabled in Cloudera Manager (Administration -> Settings -> Security), ensure that /etc/cloudera-scm-agent/config.ini has use_tls=1 on the host being added. Restart the corresponding agent and click the Retry link here.

 

And in the log:

 

 Installation failed. Failed to receive heartbeat from agent.
Ensure that the host's hostname is configured properly.
Ensure that port 7182 is accessible on the Cloudera Manager Server (check firewall rules).
Ensure that ports 9000 and 9001 are not in use on the host being added.
Check agent logs in /var/log/cloudera-scm-agent/ on the host being added. (Some of the logs can be found in the installation details).
If Use TLS Encryption for Agents is enabled in Cloudera Manager (Administration -> Settings -> Security), ensure that /etc/cloudera-scm-agent/config.ini has use_tls=1 on the host being added. Restart the corresponding agent and click the Retry link here.

I noticed "An Enterprise license is required to enable Auto-TLS. ",  is that a problem? I don't hive a Enterprise license for CDH.

Highlighted
Cloudera Employee
Posts: 78
Registered: ‎10-01-2018

Re: Enabling auto-TLS, failed to receive heartbeat from agent.

No, That's not required for TLS. It needs for LDAP and SAML etc.
https://www.cloudera.com/documentation/enterprise/5-15-x/topics/cm_ag_licenses.html#cmug_topic_13_7_...
But other things worth to check like ports and config.ini file (use_tls=1)
Posts: 1,100
Topics: 1
Kudos: 281
Solutions: 132
Registered: ‎04-22-2014

Re: Enabling auto-TLS, failed to receive heartbeat from agent.

@kernel8liang,

 

Actually, yes you do need an enterprise license to use Auto-TLS as mentioned here:

 

https://www.cloudera.com/documentation/enterprise/latest/topics/auto_tls.html#auto_tls

 

This applies to Cloudera Manager 6.0.1 and up.

 

 

Posts: 1,100
Topics: 1
Kudos: 281
Solutions: 132
Registered: ‎04-22-2014

Re: Enabling auto-TLS, failed to receive heartbeat from agent.

NOTE:

 

You can grep your /var/log/cloudera-scm-server/cloudera-scm-server.log file for the following which will be printed if Auto-TLS failed due to license restriction:

 

Did not generate Auto-TLS certificates because of missing enterprise license

 

This will appear at the time you attempted the install.

Cloudera Employee
Posts: 78
Registered: ‎10-01-2018

Re: Enabling auto-TLS, failed to receive heartbeat from agent.

@kernel8liang Apologies for Miscommunication. Please follow the solution provided by @bgooley'.