Reply
New Contributor
Posts: 1
Registered: ‎09-20-2017

Fail to start HDFS in Cluster Setup

Hi,

 

When I am trying to reinstall cloudera(I have followed the instruction in the link https://www.cloudera.com/documentation/enterprise/5-6-x/topics/cm_ig_uninstall_cm.html), there are some error messages during Cluster Setup. The Failed Steps are like the following:

   Start HDFS

   Completed only 0/1 steps. First failure: Command (40) has failed

       SeqCmdWork of 3 steps in sequence

       Command (40) has failed

           Formatting the name directories of the current NameNode. If the name directories are not empty, this is expected to fail.

           Command (40) has failed

               Format

               Failed to format NameNode.

 

and the last part of stderr message is as following:

17/09/20 20:25:08 INFO util.GSet: Computing capacity for map NameNodeRetryCache

17/09/20 20:25:08 INFO util.GSet: VM type = 64-bit

17/09/20 20:25:08 INFO util.GSet: 0.029999999329447746% max memory 253.3 MB = 77.8 KB

17/09/20 20:25:08 INFO util.GSet: capacity = 2^13 = 8192 entries

17/09/20 20:25:08 INFO namenode.FSNamesystem: ACLs enabled? false

17/09/20 20:25:08 INFO namenode.FSNamesystem: XAttrs enabled? true

17/09/20 20:25:08 INFO namenode.FSNamesystem: Maximum size of an xattr: 16384 Running in non-interactive mode, and data appears to exist in Storage Directory /dfs/nn. Not formatting.

17/09/20 20:25:08 INFO util.ExitUtil: Exiting with status 1

17/09/20 20:25:08 INFO namenode.NameNode: SHUTDOWN_MSG: /************************************************************ SHUTDOWN_MSG: Shutting down NameNode at *****************

 

If someone could point me in the right direction?

Thanks 

Announcements