Reply
Highlighted
New Contributor
Posts: 4
Registered: ‎06-12-2019
Accepted Solution

Hive queries time out

[ Edited ]

Hello!

 

My problem is to make hive queries. Using Impala works fine. Both in HUE

 

The query I tried to make is:

e.g.

load data local inpath '/tmp/expectancy_country.csv' overwrite into table expectancy_country;

 

After 2:45 i get the message time out and the log shows:

INFO  : Compiling command(queryId=hive_20190612043030_466f94db-6fb9-41c4-ad84-098d8f8decbe): load data local inpath '/tmp/expectancy_country.csv' overwrite into table expectancy_country
INFO  : Semantic Analysis Completed
INFO  : Returning Hive schema: Schema(fieldSchemas:null, properties:null)
INFO  : Completed compiling command(queryId=hive_20190612043030_466f94db-6fb9-41c4-ad84-098d8f8decbe); Time taken: 0.061 seconds

On the left side is still the red quader indicating that the query is running.

 

I also tried:

create table expectancy_country (expectancy int, country string) row format delimited fields terminated by ',';

 

With the same result. But

show tables

 

works fine.

 

The quickstart does not show any issues. The only change I made is

 

 
<property>
150150
<name>spark.executor.cores</name>
151 
- <value>1</value>
 151
+ <value>4</value>

 

But it did not work before as well. Any ideas

 

Edit:

On the upper left side under hive and databases I get the message: Error loading databases

New Contributor
Posts: 4
Registered: ‎06-12-2019

Re: Hive queries time out

I was able to solve the problem. For detailed information see this.