Expert Contributor
Posts: 66
Registered: ‎12-24-2015
Accepted Solution

Journal Node Sync - moving to new machine

[ Edited ]

We have three journal nodes. One was creating issue of sync with name node. Even after multiple rolling restart did not fix sync issue.


Later we moved, Journal node services to another node but we again got sync issue with new host’s - journal node to name node.


Another things observed here is, location /Data0/dfs/jn directory was empty on new journal node host after moving one journal node service there.


Restart of Zookeeper & Journal node did not enable creation of edit logs on new host as well. We have also tried to move everything from working/old JN's location /Data0/dfs/jn/hanameservice/* to new host as per below section.


Can you please suggest, how to enable sync of Journal node with namenode or what step actually we are missing here?


CDH - 5.4.+





Cloudera Employee
Posts: 8
Registered: ‎04-22-2014

Re: Journal Node Sync - moving to new machine

Hi Kartik,

Have you tried following these steps:


Otherwise, if you can bring down HDFS, you can do the following:

1. Stop HDFS service

2. Copy over JN edits from a (good) JN to the (bad) JN. Make sure you get all edits from all dirs (

3. Start HDFS service
Let me know if that works for you.
Posts: 18
Registered: ‎10-03-2015

Re: Journal Node Sync - moving to new machine


I just want to say that we succesfully added two extra JNs to our HA cluster* by following the 3 steps procedure suggested here.


For copying content over to new JNs we used rsync, very handy!




* running CDH 5.9.1 on centos 6.7 machines

Posts: 21
Registered: ‎10-12-2015

Re: Journal Node Sync - moving to new machine

It seems really strange that the process of adding in a new JournalNode doesn't DO THIS FOR YOU. Basically, if you change or add journalnodes to your setup, nothing will work until/unless you do this behind the scenes stuff. WHY?

Posts: 17
Registered: ‎11-08-2018

Re: Journal Node Sync - moving to new machine



I have three Journal Nodes, I am facing same issue for 2 Journal Nodes. So i have copied the JournalEdits from good JN to bad JN like two other JN's and restarted.

But still i am seeing same sync issue and can see below errors.

 Cannot locate configuration: tried,


ERROR org.apache.hadoop.hdfs.qjournal.server.JournalNode RECEIVED SIGNAL 15: SIGTERM
WARN org.apache.hadoop.metrics2.impl.MetricsConfig Cannot locate configuration: tried,


Thanks in advance....!!