Reply
Cloudera Employee
Posts: 578
Registered: ‎01-20-2014

Re: Zookeeper installation error

Is /pkg/moip/mo10755/work/mzpl/cloudera/parcels or any of the directories
in between on a remote host or a separate mount? Do any of the mounts have
a noexec option? Run the mount command and see the flags set

​Check the #! line in the script, what shell does it refer to? Is that
program present on your box?

What user are you running the test as? 766 implies "other" cannot execute
the script.

To verify if the cloudera-scm user is valid, run the /bin/id command on it
(as root)
# /bin/id cloudera-scm​

Does the uid and gid match that in /etc/passwd?​

Regards,
Gautam Gopalakrishnan
Highlighted
Contributor
Posts: 39
Registered: ‎09-20-2014

Re: Zookeeper installation error

I solved the problem.

 

cloudera-scm user did not have access to a parent folder: /pkg/moip/mo10755/work/mzpl which caused that the cloudera-scm user could not run any scripts from parcel subfolders.

 

I changed the permissions and now it works :)

 

Thank you very much for your help!