Reply
New Contributor
Posts: 2
Registered: ‎03-14-2014

error during "yum install hue-plugins" Cloudera 5 Beta2

python2.6 is installed still yum install hue-plugins throws an error "Error: Package: hue-common-3.5.0+cdh5.0.0+186-0.cdh5b2.p0.22.el5.x86_64 (cloudera-cdh5)
Requires: python26 "

 

Any ideas?

 

[root@r01wn01 yum.repos.d]# yum info python
Loaded plugins: product-id, security, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Installed Packages
Name : python
Arch : x86_64
Version : 2.6.6
Release : 36.el6
Size : 20 M
Repo : installed
From repo : RHEL64
Summary : An interpreted, interactive, object-oriented programming language
URL : http://www.python.org/
License : Python
Description : Python is an interpreted, interactive, object-oriented programming
: language often compared to Tcl, Perl, Scheme or Java. Python includes
: modules, classes, exceptions, very high level dynamic data types and
: dynamic typing. Python supports interfaces to many system calls and
: libraries, as well as to various windowing systems (X11, Motif, Tk,
: Mac and MFC).
:
: Programmers can write new built-in modules for Python in C or C++.
: Python can be used as an extension language for applications that need
: a programmable interface. This package contains most of the standard
: Python modules, as well as modules for interfacing to the Tix widget
: set for Tk and RPM.
:
: Note that documentation for Python is provided in the python-docs
: package.

 

 

[root@r01wn01 yum.repos.d]# yum install hue-plugins
Loaded plugins: product-id, security, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package hue-plugins.x86_64 0:3.5.0+cdh5.0.0+186-0.cdh5b2.p0.22.el5 will be installed
--> Processing Dependency: hue-common = 3.5.0+cdh5.0.0+186-0.cdh5b2.p0.22.el5 for package: hue-plugins-3.5.0+cdh5.0.0+186-0.cdh5b2.p0.22.el5.x86_64
--> Running transaction check
---> Package hue-common.x86_64 0:3.5.0+cdh5.0.0+186-0.cdh5b2.p0.22.el5 will be installed
--> Processing Dependency: python26 for package: hue-common-3.5.0+cdh5.0.0+186-0.cdh5b2.p0.22.el5.x86_64
--> Finished Dependency Resolution
Error: Package: hue-common-3.5.0+cdh5.0.0+186-0.cdh5b2.p0.22.el5.x86_64 (cloudera-cdh5)
Requires: python26
You could try using --skip-broken to work around the problem

 

New Contributor
Posts: 2
Registered: ‎03-14-2014

Re: error during "yum install hue-plugins" Cloudera 5 Beta2

Never mind! A silly mistake from my side. 

Highlighted
New Contributor
Posts: 2
Registered: ‎05-15-2015

Re: error during "yum install hue-plugins" Cloudera 5 Beta2

Hi Joe, I have met this error, but I don't know why this happened, could you please kindly tell me how you resolved this if you still remember after so long time ? Thank you very much!

 

My OS : Centos 6.5 x86_64

python : 2.6.6

 

And I tried python 2.7.9, still not work.

yum info python 

Loaded plugins: fastestmirror, refresh-packagekit, security
Loading mirror speeds from cached hostfile
* base: ftp.sjtu.edu.cn
* extras: mirrors.skyshe.cn
* updates: ftp.sjtu.edu.cn
Installed Packages
Name : python
Arch : x86_64
Version : 2.6.6
Release : 52.el6
Size : 78 k
Repo : installed
From repo : base
Summary : An interpreted, interactive, object-oriented programming language
URL : http://www.python.org/
License : Python
Description : Python is an interpreted, interactive, object-oriented programming
: language often compared to Tcl, Perl, Scheme or Java. Python includes
: modules, classes, exceptions, very high level dynamic data types and
: dynamic typing. Python supports interfaces to many system calls and
: libraries, as well as to various windowing systems (X11, Motif, Tk,
: Mac and MFC).
:
: Programmers can write new built-in modules for Python in C or C++.
: Python can be used as an extension language for applications that need
: a programmable interface.
:
: Note that documentation for Python is provided in the python-docs
: package.
:
: This package provides the "python" executable; most of the actual
: implementation is within the "python-libs" package.

 

 

New Contributor
Posts: 2
Registered: ‎05-15-2015

Re: error during "yum install hue-plugins" Cloudera 5 Beta2

Alright, I found the silly mistake, That is really silly.

Explorer
Posts: 14
Registered: ‎02-10-2015

Re: error during "yum install hue-plugins" Cloudera 5 Beta2

Hello,

 

Could you please tell me how did you resolve this?

 

 

-Pankaj

New Contributor
Posts: 1
Registered: ‎07-20-2017

Dependency Resolution failed due python26

I'm facing the same issue :( any suggestion is welcome..

 

--> Finished Dependency Resolution
Error: Package: hue-common-3.9.0+cdh5.7.1+1804-1.cdh5.7.1.p0.14.el5.x86_64 (cloudera571)
           Requires: python26
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

 

[root@localhost yum.repos.d]# yum info python
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: centos.mia.host-engine.com
 * extras: chicago.gaminghost.co
 * updates: repos.dfw.quadranet.com
Installed Packages
Name        : python
Arch        : x86_64
Version     : 2.6.6
Release     : 66.el6_8
Size        : 78 k
Repo        : installed
From repo   : anaconda-CentOS-201703281317.x86_64
Summary     : An interpreted, interactive, object-oriented programming language
URL         : http://www.python.org/
License     : Python
Description : Python is an interpreted, interactive, object-oriented programming
            : language often compared to Tcl, Perl, Scheme or Java. Python includes
            : modules, classes, exceptions, very high level dynamic data types and
            : dynamic typing. Python supports interfaces to many system calls and
            : libraries, as well as to various windowing systems (X11, Motif, Tk,
            : Mac and MFC).
            :
            : Programmers can write new built-in modules for Python in C or C++.
            : Python can be used as an extension language for applications that need
            : a programmable interface.
            :
            : Note that documentation for Python is provided in the python-docs
            : package.
            :
            : This package provides the "python" executable; most of the actual
            : implementation is within the "python-libs" package.