Reply
Expert Contributor
Posts: 66
Registered: ‎12-24-2015

Failed to configure urlScheme property for Solr cluster in Zookeeper

I have set three zookeepers services. they are working fine one leader and two follower. But Solr is not able to start due to some property is not available. where to set this property ?

 

I have done setup using Cloudera director - 2.0, CDH 5.5.2

 

Failed to configure urlScheme property for Solr cluster in Zookeeper

using 5 as CDH_VERSION
Unable to set the cluster property due to following error : Error updating cluster property urlScheme
Error: Unable to set the cluster property in ZK
Failed to configure urlScheme property for Solr cluster in Zookeeper
Tue May 17 06:13:53 EDT 2016

Cloudera Employee
Posts: 275
Registered: ‎01-09-2014

Re: Failed to configure urlScheme property for Solr cluster in Zookeeper

Have you ever had solr up and running in this cluster?  Do you have any active collections?

 

One thing to try is to perform an "Initialize Solr" action from CM  (from within the solr service), when the solr service is shut down.  If solr has not been initialized in ZK, you could get your observed error.

 

-pd

Expert Contributor
Posts: 66
Registered: ‎12-24-2015

Re: Failed to configure urlScheme property for Solr cluster in Zookeeper

 

Setting up cluster first time using lastest director 2.0 and CDH 5.5X.

is  "Initialize Solr" action from CM  is same as start Solr ? I have tried start solr many times. it did not work.

Highlighted
Cloudera Employee
Posts: 275
Registered: ‎01-09-2014

Re: Failed to configure urlScheme property for Solr cluster in Zookeeper

No, initialize solr usually happens when the service is installed, but it may not have if you installed from director.  It is in the Actions drop down menu, and grayed out when solr is running