Posts: 72
Registered: ‎01-19-2017
Accepted Solution

Unable to Create Solr Collection

[ Edited ]

I tried to delete the collection using the below command


solrctl --zk ${ZOOKEEPER_CONNECT} collection --delete COLLECTION_NAME;


while issued the command it takes more than 10 mins. so I given force exit with key ctrl+c


When i checking the solr Admin console. I found like the collection was deleted.there is no entry in the core Selector


But when i checked with solrctrl command i found like entry is there for the collection.


solrctl --zk ${ZOOKEEPER_CONNECT} collection --list


it seems like ZOOKEEPER somewhere storing the collection information.


and then i tried to create the collection with the command


solrctl --zk ${ZOOKEEPER_CONNECT} collection --create COLLECTION_NAME -s 2 -r 2


It gets hanged with the command . its does not thrown any error. it keeps on running with  no reponse.

Posts: 72
Registered: ‎01-19-2017

Re: Unable to Create Solr Collection

I solved this issue by simply restarting the Solr from cloudera manager.

Cloudera Employee
Posts: 25
Registered: ‎08-22-2014

Re: Unable to Create Solr Collection

Were you running the above commands from one of the solr nodes or the node which had the solr gateway on it?

Did you have any solr node down when you were deleting or creating a collection as taking time issue can happen that time?

Did you see any unexpected exits with solr like out of memory issues?


As taking the time can either happen when no solr gateway but that time it will throw some error after a certain time.


or if you had any shard down for the collection you were trying to delete then restart may have helped with that.