Posts: 72
Registered: ‎01-19-2017
Accepted Solution

cloudera upgradation problem from 5.48 to 5.9.2

I have 5 node cluster and using ISILON for hdfs storage and tried to upgrade both isilon onefs and cloudera cluster from 5.4.8 version to 5.9.2 version


Below are the commands i issued in the machines before proceed from the cloudera manager UI,


step1: sudo service cloudera-scm-server stop

step2: sudo service cloudera-scm-agent stop

step3: Upgrade ISILON (done on isilon machines)

step4: issued command in cloudera manager server machine

sudo yum clean all
sudo yum upgrade cloudera-manager-daemons cloudera-manager-server
step5: issued command in cloudera manager agent machines
sudo yum clean all
sudo yum upgrade cloudera-manager-agent cloudera-manager-daemons
step6: sudo service cloudera-scm-server start
sudo service cloudera-scm-agent next_stop_hard
sudo service cloudera-scm-agent restart
once login into the cloudera manager getting below log once try to restart the cloudera management service
ERROR 1110082230@scm-web-22:org.mortbay.log: /cmf/role/24/tail
at org.springframework.web.servlet.view.RedirectView.appendQueryProperties(
at org.springframework.web.servlet.view.RedirectView.renderMergedOutputModel(
at org.springframework.web.servlet.view.AbstractView.render(
at org.springframework.web.servlet.DispatcherServlet.render(
at org.springframework.web.servlet.DispatcherServlet.doDispatch(
at org.springframework.web.servlet.DispatcherServlet.doService(
at org.springframework.web.servlet.FrameworkServlet.processRequest(
at org.springframework.web.servlet.FrameworkServlet.doGet(
at javax.servlet.http.HttpServlet.service(
at javax.servlet.http.HttpServlet.service(
at org.mortbay.jetty.servlet.ServletHolder.handle(
at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(
at org.mortbay.servlet.UserAgentFilter.doFilter(
at org.mortbay.servlet.GzipFilter.doFilter(
at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(Servlet
 please help me to solve it.


Posts: 72
Registered: ‎01-19-2017

Re: cloudera upgradation problem from 5.48 to 5.9.2

I missed to install Cloudera manager  agent in the Cloudera manager server instance. Once I installed the problem has solved

Posts: 937
Kudos: 112
Solutions: 60
Registered: ‎04-06-2015

Re: cloudera upgradation problem from 5.48 to 5.9.2

Congratulations on solving your issue and thanks for sharing the solution. Best of luck moving forward. :)

Cy Jervis, Community Manager

Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.

Learn more about the Cloudera Community:

Terms of Service

Community Guidelines

How to use the forum