Code Repositories

Find and share code repositories
Welcome to the upgraded Community! Read this blog to see What’s New!
Labels (2)
Repo Description

Ambari stack for easily installing and managing HDP IoT Demo which shows real time monitoring/alerts and predictions of driving violations generated by fleet of trucks. Also has optional steps to setup Ranger audits to Solr and a SILK dashboard to visualize audits

Videos on the demo itself available here:

Repo Info
Github Repo URL
Github account name abajwa-hw
Repo name iotdemo-service

Awesome stuff, Ali. Thank you! I've installed this on the sandbox without any issues and I was preparing to get it running on a small demo cluster. Have you attempted to install the service on a cluster and were there any quirks we should look out for during that install (other than the ambari vs ambari-server commands)? If not I'll try it out and let you know what, if any, additional steps were needed to get it running.

Thanks @Henry Sowell! Yes we have deployed this multiple clusters in Openstack, AWS, Azure etc and it seems to work fine. The limitations of the current demo are outlined in the github README e.g. to automate creation of kafka topics, kafka and iotdemo services should be co-located on ambari server

Expert Contributor

Hi, @Ali Bajwa. I am having issues installing the demo on sandbox 2.5. Are there any extra steps involved? Thank you

@Roger Young The ambari service and instructions has been updated for hdp 2.5, (make sure to use hdp25 branch): but I think it requires a lot more memory than is available on default sandbox

The easiest way to get the demo up might be to use the prebuilt Amazon AMI to spin it up on AWS:

Expert Contributor

Hi @Ali Bajwa. Thank you for the info. I have tried many times to follow the link to install on 2.5 but keep getting the following error. The IoTDemo install fails immediately with this error.

resource_management.core.exceptions.Fail: Execution of 'cd /root; git clone >> /var/log/iotdemo.log' returned 128. fatal: could not create work tree dir 'hdp'.: Invalid argument

@Roger Young Sounds like root user is unable to create dir /root/hdp. As root user, can you manually try creating this dir and see what error you get? (e.g. mkdir /root/hdp). If you are running this on HDP 2.5 sandbox, note that it is docker based and we have encountered these type of filesystem issues (esp older versions of 2.5 sandbox)

Expert Contributor

Hi @Ali Bajwa. I tried creating the hdp folder manually and got the same error, but was able to create other folders such as HDP, strange. I might reinstall and try again, thank you.