Code Repositories
Find and share code repositories
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.
Labels (2)
Guru
Repo Description

This reporting task is designed to work with the Credit Fraud Prevention Demo.https://community.hortonworks.com/content/repo/27236/credit-fraud-prevention-demo.html

However, the Reporting Task will work with on it's own. When running stand alone, two new Atlas types must be applied using the Atlas REST API.

Repo Info
Github Repo URL https://github.com/vakshorton/NifiAtlasLineageReporter.git
Github account name vakshorton
Repo name NifiAtlasLineageReporter.git
2,716 Views
Comments
New Contributor

Hi Vadim,

Can you provide the Nar file for the AtlasLineagereporting task?

Preethi

Contributor

Hi Vadim,

I have created a Hortonworks VM on Azure, ran the install script . it was looping at below statement

curl: (7) couldn't connect to host *********************************Waiting for NIFI Servlet... *********************************NIFI Servlet Status... PENDING

All the applications are running fine except the Nifi Service. I am seeing the below error in nifi applogs

2016-12-15 00:09:17,285 ERROR [main] org.apache.nifi.NiFi Failure to launch NiFi due to java.lang.UnsupportedClassVersionError: org/apache/nifi/atlas/reporting/AtlasFlowReportingTask : Unsupported major.minor version 52.0 java.lang.UnsupportedClassVersionError: org/apache/nifi/atlas/reporting/AtlasFlowReportingTask : Unsupported major.minor version 52.0

Could you please let me know how to resolve this issue.

Not applicable

Getting following error while installing on Sandbox 2.4, seems java version conflict :

p.p1 {margin: 0.0px 0.0px 0.0px 0.0px; font: 11.0px Menlo} span.s1 {font-variant-ligatures: no-common-ligatures}

2017-01-02 20:54:23,439 INFO [main] o.a.n.c.repository.FileSystemRepository Initializing FileSystemRepository with 'Always Sync' set to false

2017-01-02 20:54:24,312 ERROR [main] org.apache.nifi.NiFi Failure to launch NiFi due to java.lang.UnsupportedClassVersionError: org/apache/nifi/atlas/reporting/AtlasFlowReportingTask : Unsupported major.minor version 52.0

java.lang.UnsupportedClassVersionError: org/apache/nifi/atlas/reporting/AtlasFlowReportingTask : Unsupported major.minor version 52.0

at java.lang.ClassLoader.defineClass1(Native Method) ~[na:1.7.0_95]

at java.lang.ClassLoader.defineClass(ClassLoader.java:800) ~[na:1.7.0_95]

at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142) ~[na:1.7.0_95]

at java.net.URLClassLoader.defineClass(URLClassLoader.java:449) ~[na:1.7.0_95]

at java.net.URLClassLoader.access$100(URLClassLoader.java:71) ~[na:1.7.0_95]

at java.net.

Don't have an account?
Coming from Hortonworks? Activate your account here
Version history
Revision #:
1 of 1
Last update:
‎06-13-2016 09:22 PM
Updated by:
 
Contributors
Top Kudoed Authors