Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st. We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here. Need help or have questions? Drop us a line at [email protected]
SYMPTOM: During upgrade from HDP 2.4.3 to HDP2.6.0 the express upgrade failed on the step "Yarn NodeMangers / Restarting NodeManger."
ERROR:
2017-06-22
15:02:22,791 INFO recovery.ZKRMStateStore
(ZKRMStateStore.java:runWithRetries(1227)) - Exception while executing a ZK
operation. org.apache.zookeeper.KeeperException$AuthFailedException:
KeeperErrorCode = AuthFailed for /rmstore at
org.apache.zookeeper.KeeperException.create(KeeperException.java:123) at
org.apache.zookeeper.KeeperException.create(KeeperException.java:51) at
org.apache.zookeeper.ZooKeeper.create(ZooKeeper.java:783)
ROOT CAUSE: The issue was with property Ambari-Yarn-Configs-"yarn-resourcemanager-zk-address" was set to localhost:2181
RESOLUTION:
Modified address to "{zk-server-hostname}:2181" resolved the issue. After which node managers were able to start successfully.