Community Articles
Find and share helpful community-sourced technical articles
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.
Labels (1)
Cloudera Employee

After upgrading Ambari (not entirely sure which version but think it was Ambari 2.4.2 to 2.5.0.3), Smartsense View came up unavailable with these messages:

"Service Unavailable"

"The SmartSense service is currently unavailable. Please make sure the SmartSense Server is up and running."

See screenshot

19466-smartsense-view-error.png

In the /var/log/ambari-server/ambari-server.log log you many see entries like this when you click on the Smartsense view.

14 Jul 2017 11:14:05,523 ERROR [ambari-client-thread-467377] ServerProxy:162 - Failed to execute GET /recommendations. Reason: Connection refused
14 Jul 2017 11:14:14,734 ERROR [ambari-client-thread-467506] ServerProxy:162 - Failed to execute GET /context. Reason: Connection refused
14 Jul 2017 11:14:14,900 ERROR [ambari-client-thread-467507] ServerProxy:162 - Failed to execute GET /checkconfig. Reason: Connection refused

diff'ing the hst-server.ini config file against previous saved config versions yielded this:

# diff conf/hst-server.ini conf_13_04_17_04_17.save/
2,4d1
< enable.flex.subscription = false
< smartsense.id=X-00000000-X-00000000
< flex.subscription.id =
6a4
> smartsense.id=X-00000000-X-00000000
27,28d24
< url = http://:9000
< max.heap = 2048
30d25
< run.as.user =
33d27
< version = 1.4.0.2.5.0.3-7
52,57d45
< [recommendation]
< auto.download.interval = 300
< feedback.push.maxentries = 50
< feedback.push.interval = 1800
< expiry = 30
<

Was missing a valid hostname in the url property.

Find this in Ambari Smartsense Config tab under Advanced hst-server-conf and add the hostname of the HST server to the server.url property (can't share the screenshot because weirdly his property ghosted into view but now I can't re-find it in Ambari - know it's there because under the [server] section in the hst-server.ini there is a url = http://<hst server name>:9000 - this strangeness was probably the reason it took me so long to find the issue in the first place).

Restart Smartsense via Ambari and the Smartsense View was working as usual.

1,110 Views
0 Kudos
Don't have an account?
Coming from Hortonworks? Activate your account here
Version history
Revision #:
2 of 2
Last update:
‎08-17-2019 11:57 AM
Updated by:
 
Contributors
Top Kudoed Authors