New Contributor
Posts: 1
Registered: ‎03-08-2017

Navigator Api Config File Null Pointer Error

[ Edited ]



I am using the Navigator Api, I rearranging a previously working Navigator Api project which worked fine.

But for some reason now when ever i attempted to initalise a new Navigator Plug in i get a null pointer error which i am un able to fix the errors always seem to occur with configFile.


NavigatorPlugin sdk = NavigatorPlugin.fromConfigFile(url.getPath());


I have also tried creating a Map of the config statements and passing that with.


NavigatorPlugin sdk = NavigatorPlugin.fromConfigMap(configMap);


For some reason the Api is forcing me to give values for every statement in the config file. Some of which i dont want to set and othere such as namespace which i dont know how to set properly and even with setting the majority of them namespace still gives me an error.


I was wondering if anyone had come across this before?


Config File:

# this is the URL of the client application

# Replace localhost:7187 with actual navigator URL

# Minimum is version 7 for publishing metadata to Navigator
# Version 9 is minimum for typed custom property support

# Designator for client application
# This will be used as the meta class package and custom property namespace

# Navigator username and password

# From @
# By default, Navigator throttles its own internal committing process so that new metadata
# won't be available immediately. For testing and development, you can add a
# configuration variable "autocommit=true".
# This disables this lag and adds assigned metadata straight away


New solutions