New Contributor
Posts: 7
Registered: ‎06-25-2014
Accepted Solution

Couldn't start sqoop2 job



I am trying to transfer data from Oracle into HDFS. I copied JDBC driver (ojdbc6.jar) into /var/lib/sqoop2 and also 

/opt/cloudera/parcels/CDH-5.0.2-1.cdh5.0.2.p0.13/lib/sqoop2 for sure. But when I create job and start it, message - Error, could not start job is shown. I also tried to run job from CLI:


start job --jid 4

 But got this message:

Exception has occurred during processing command
Exception: org.apache.sqoop.common.SqoopException Message: CLIENT_0001:Server has returned exception

 This error message doesn't help me, it is not too verbose. Do you know where the problem should be? Connection should be ok, and table and schema exists in oracle database. Here is connection and job info:



Job with id 4 and name Test job (Enabled: true, Created by rtomsej at 7/8/14 8:42 AM, Updated by rtomsej at 7/8/14 8:42 AM)
Using Connection id 5 and Connector id 1
  Database configuration
    Schema name: ibp
    Table name: open_nl_cnt
    Table SQL statement:
    Table column names:
    Partition column name:
    Nulls in partition column: true
    Boundary query:
  Output configuration
    Storage type: HDFS
    Output format: TEXT_FILE
    Compression format: NONE
    Output directory: /user/rtomsej/ibp
  Throttling resources


Connection with id 5 and name Oracle-Web (Enabled: true, Created by rtomsej at 7/8/14 8:41 AM, Updated by rtomsej at 7/8/14 8:53 AM)
Using Connector id 1
  Connection configuration
    JDBC Driver Class: oracle.jdbc.driver.OracleDriver
    JDBC Connection String: jdbc:oracle:thin:@localhost:1521
    Username: localhost
    JDBC Connection Properties:
  Security related configuration options
    Max connections:

 We are using CDH5.0.2 with parcels.


Thank you

Cloudera Employee abe
Cloudera Employee
Posts: 109
Registered: ‎08-08-2013

Re: Couldn't start sqoop2 job

Hey there,


Would you mind setting the verbosity option and running your job?


set option --name verbose --value true


Also, /var/log/sqoop2/sqoop.log should have errors. Could you please dig for any errors there and post them to this thread?



New Contributor
Posts: 7
Registered: ‎06-25-2014

Re: Couldn't start sqoop2 job

Thank you Abe, it seams that problem was missing partition columns. So I tried to add one column and job started. But it would be great to receive this information also from Hue.

New solutions