Reply
Highlighted
Explorer
Posts: 21
Registered: ‎12-16-2014

Kafka in Cluster mode fails

Hi All,

 

I setup Kafka in Cluster mode, with 2 nodes. Id = 1,2. When started, the kafka always fails, with these messages  - 

 

ERROR xxxxxxxx.OutputHandlers.QueueLayer - System.AggregateException: One or more errors occurred. ---> System.AggregateException: One or more errors occurred. ---> KafkaNet.Protocol.LeaderNotFoundException: Lead broker cannot be found for parition: 0, leader: -1
at KafkaNet.BrokerRouter.GetCachedRoute(String topic, Partition partition)
at KafkaNet.Producer.<ProduceAndSendBatchAsync>b__2a(TopicMessage batch)
at System.Linq.Enumerable.WhereSelectEnumerableIterator`2.MoveNext()
at System.Linq.Lookup`2.Create[TSource](IEnumerable`1 source, Func`2 keySelector, Func`2 elementSelector, IEqualityComparer`1 comparer)
at System.Linq.GroupedEnumerable`3.GetEnumerator()
at KafkaNet.Producer.<ProduceAndSendBatchAsync>d__3d.MoveNext()
--- End of inner exception stack trace ---
at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at KafkaNet.Producer.<SendMessageAsync>d__d.MoveNext()
--- End of inner exception stack trace ---
at System.Threading.Tasks.Task.Wait(Int32 millisecondsTimeout, CancellationToken cancellationToken)
at xxxxxxx.OutputHandlers.QueueLayer.WriteToQueue(String kafkaTopic, KeyValuePair`2 data) in

 

 

CDH - 5.5

Kafka Version - kafka_2.11-0.8.2.1

CentOS - 6.7

 

 

Thanks in Advance.