Reply
Highlighted
New Contributor
Posts: 6
Registered: ‎08-18-2014
Accepted Solution

Pig Editor Error- ErrorCode [EJ001], Message [Could not locate Oozie sharelib] on QuickStart VM

Hi,

 

I am new to Hadoop. I am trying to run below basic statement in Pig Editor. I am using Cloudera Quickstart VM.

                   sample_07 = LOAD 'sample_07' USING org.apache.hcatalog.pig.HCatLoader();

 

However, I am getting below error while running the script. I have not added any properties at the time of run. Please help.

 

           ErrorCode [EJ001], Message [Could not locate Oozie sharelib]

 

Thanks

Sach

 

New Contributor
Posts: 6
Registered: ‎08-18-2014

Re: Pig Editor Error- ErrorCode [EJ001], Message [Could not locate Oozie sharelib] on QuickStart VM

Hi,

 

  Please help on this.

 

Thanks

Sach

New Contributor
Posts: 2
Registered: ‎08-19-2014

Re: Pig Editor Error- ErrorCode [EJ001], Message [Could not locate Oozie sharelib] on QuickStart VM

Hi.

 

I had the same problem. It turns out that they have a bug in the VM, misconfigured oozie service.

 

What I did is:

1. Open CDH VM in VMWare Player / Workstation

2. Open system console - appears on top desktop's toolbar

3. Write the following lines:

3.1. sudo service oozie stop

3.2. sudo oozie-setup sharelib create -fs /user/oozie/share/lib/mr1 -locallib /usr/lib/oozie/oozie-sharelib-mr1.tar.gz 

3.3. sudo service oozie start

 

Then try running Pig script again. Worked for me.

 

What this does is reinstalling share/lib required libraries.

See details here: http://www.cloudera.com/content/cloudera-content/cloudera-docs/CDH5/latest/CDH5-Installation-Guide/c...

 

Hope it helps you too.

 

David.

New Contributor
Posts: 6
Registered: ‎08-18-2014

Re: Pig Editor Error- ErrorCode [EJ001], Message [Could not locate Oozie sharelib] on QuickStart VM

Thanks a lot, David.

 

I am able to move forward and stuck with below error while running Pig script.

 

 

[main] ERROR org.apache.pig.tools.grunt.Grunt - ERROR 2245: Cannot get schema from loadFunc org.apache.hcatalog.pig.HCatLoader

 

Please advice.

 

Thanks

Sach

New Contributor
Posts: 2
Registered: ‎08-19-2014

Re: Pig Editor Error- ErrorCode [EJ001], Message [Could not locate Oozie sharelib] on QuickStart VM

I am not familiar with this error but Googling around leads me to this, maybe it helps: http://stackoverflow.com/questions/22304947/cannot-load-hive-table-into-pig-via-hcatalog

 

New Contributor
Posts: 6
Registered: ‎08-18-2014

Re: Pig Editor Error- ErrorCode [EJ001], Message [Could not locate Oozie sharelib] on QuickStart VM

 
New Contributor
Posts: 6
Registered: ‎08-18-2014

Re: Pig Editor Error- ErrorCode [EJ001], Message [Could not locate Oozie sharelib] on QuickStart VM

Hi,

 

After adding site_hive.xml file to pig script using properties, I am able to run pig scripts.  

 

Thanks for all your help.

 

Sach

Announcements

Our community is getting a little larger. And a lot better.


Learn More about the Cloudera and Hortonworks community merger planned for late July and early August.