New Contributor
Posts: 4
Registered: ‎01-07-2016

issue trying Impyla

I am trying the sample impyla code from


And getting "impala.error.HiveServer2Error: Failed after retrying 3 times"


impyla is installed on the hadoop (CDH-5.3.2) node I log in to




from impala.dbapi import connect
conn = connect(host='', port=21050)
cursor = conn.cursor()
cursor.execute('SELECT * FROM youval_db.accounts_info LIMIT 10')
print cursor.description # prints the result set's schema
results = cursor.fetchall()

Where for  "" I used the the impala host I got from the cloudera manager.

(tried with host from the following groups: Impala Catalog Server Default Group, Impala Daemon Default Group and Impala StateStore Default Group)


got the same error for All.


Also tried with 

conn = connect()

It did not work as well.


Any suggestion on how to make it work?


New Contributor
Posts: 3
Registered: ‎04-12-2017

Re: issue trying Impyla

Been getting the same error when I was trying to connect to the impala instance on a kerberized cluster! Any particular reason why we get this??