Reply
New Contributor
Posts: 2
Registered: ‎05-08-2016

Kafka 1.2.x gives a warning of incompatible CDH distribution

I installed Cloudera 5.5.0 quicksrtart vm and trying to install kafka 1.2.0. according to the link: http://www.cloudera.com/documentation/kafka//1-2-x/topics/kafka_install.html

 

Once I install, distribute CSD, I get the message that KAFKA 2.01-1.2.0.1.p0.5 is not compatible with CDH Version, which should be > 5.2 at the time of activation. I am using CDH 5.5 though on my VM.

 

Below is the output of CDH_version.propertiesa for your reference.

 

[cloudera@quickstart csd]$ cat /usr/lib/hadoop/cloudera/cdh_version.properties

# Autogenerated build properties
version=2.6.0-cdh5.7.0
git.hash=c00978c67b0d3fe9f3b896b5030741bd40bf541a
cloudera.hash=c00978c67b0d3fe9f3b896b5030741bd40bf541a
cloudera.cdh.hash=e7465a27c5da4ceee397421b89e924e67bc3cbe1
cloudera.cdh-packaging.hash=8f9a1632ebfb9da946f7d8a3a8cf86efcdccec76
cloudera.base-branch=cdh5-base-2.6.0
cloudera.build-branch=cdh5-2.6.0_5.7.0
cloudera.pkg.version=2.6.0+cdh5.7.0+1280
cloudera.pkg.release=1.cdh5.7.0.p0.92
cloudera.cdh.release=cdh5.7.0
cloudera.build.time=2016.03.23-18:30:29GMT

 

Is there any workaround to fix the compatibility issues. I believe the cloudera manager is getting the version from wrong place.

 

Thanks!

Cloudera Employee
Posts: 435
Registered: ‎07-12-2013

Re: Kafka 1.2.x gives a warning of incompatible CDH distribution

The problem is that you can't mix parcels and Linux packages. The error
message is because Cloudera Manager is looking for a CDH parcel, but CDH is
installed in the VM using Linux packages (so that Manager is optional). If
you want to use the Kafka parcel, you will first need to install the CDH
parcel - there's a script on the desktop you can run that will migrate from
the package install to a parcel install, restart the services, etc.. After
that you should be able to install the Kafka parcel.