Reply
Highlighted
New Contributor
Posts: 1
Registered: ‎02-06-2019

Kafka: "major minor version mismatch" error in Quickstart VM

[ Edited ]

As kafka is not part of Quickstart VM, I downloaded Kafka to VM. 

 

Able to start Zookeeper

 

 

bin/zookeeper-server-start.sh config/zookeeper.properties

 

Zookeeper.PNG

 

 

When I try to start Kafka server in quickstart vm, get the error "unsupported major.minor version"

 

 

bin/kafka-server-start.sh config/server.properties

 

 Error.PNG

 

Version of Java available in VM is mentioned in above screenshot

Pls advice how to proceed

 

 

 

New Contributor
Posts: 1
Registered: ‎09-18-2018

Re: Kafka: "major minor version mismatch" error in Quickstart VM

Download requied version of kafka parcel and csd from cloudera repo: http://archive.cloudera.com/kafka and install kafka service via CM. Kafka RPMs also available on this repo in case you need it in Quickstat VM.

 

Before downloaod kafka version check JDK requirement from : https://www.cloudera.com/documentation/kafka/latest/topics/kafka_requirements.html#concept_pdd_kzf_v... and https://www.cloudera.com/documentation/enterprise/release-notes/topics/rn_consolidated_pcm.html#pcm_...