Reply
New Contributor
Posts: 1
Registered: ‎02-26-2015

Multiple issues for first time user

Hi,

I am having multiple problems with my trial, probably related to the fact that I don't know what I am doing really.

First, when I try to launch Cloudera Manager, I try to go to the webpage: http://216.121.117.82:7180/ but I get a message that my connection was refused. http://216.121.117.82/# works so I am not sure what is going on.

I also get the following message when running the first tutorial.

[root@eed77-cldramaster-01 ~]# sqoop import-all-tables \ -m 12 \ --connect jdbc:mysql://eed77-cldramaster-01:3306/retail_db \ --username=retail_dba \ --password=cloudera \ --compression-codec=snappy \ --as-avrodatafile \ --warehouse-dir=/user/hive/warehouse
Warning: /opt/cloudera/parcels/CDH-5.2.0-1.cdh5.2.0.p0.36/bin/../lib/sqoop/../accumulo does not exist! Accumulo imports will fail.
Please set $ACCUMULO_HOME to the root of your Accumulo installation.
15/02/26 09:43:11 INFO sqoop.Sqoop: Running Sqoop version: 1.4.5-cdh5.2.0
15/02/26 09:43:11 ERROR tool.BaseSqoopTool: Error parsing arguments for import-all-tables:
15/02/26 09:43:11 ERROR tool.BaseSqoopTool: Unrecognized argument: -m
15/02/26 09:43:11 ERROR tool.BaseSqoopTool: Unrecognized argument: 12
15/02/26 09:43:11 ERROR tool.BaseSqoopTool: Unrecognized argument: --connect
15/02/26 09:43:11 ERROR tool.BaseSqoopTool: Unrecognized argument: jdbc:mysql://eed77-cldramaster-01:3306/retail_db
15/02/26 09:43:11 ERROR tool.BaseSqoopTool: Unrecognized argument: --username=retail_dba
15/02/26 09:43:11 ERROR tool.BaseSqoopTool: Unrecognized argument: --password=cloudera
15/02/26 09:43:11 ERROR tool.BaseSqoopTool: Unrecognized argument: --compression-codec=snappy
15/02/26 09:43:11 ERROR tool.BaseSqoopTool: Unrecognized argument: --as-avrodatafile
15/02/26 09:43:11 ERROR tool.BaseSqoopTool: Unrecognized argument: --warehouse-dir=/user/hive/warehouse
Try --help for usage instructions.


I suspect there are pretty basic things that I have not set up correctly, but I don't know what to do.

 

Thanks,

Tim

Cloudera Employee
Posts: 435
Registered: ‎07-12-2013

Re: Multiple issues for first time user

Your link on port 7180 works fine for me (at least to connect and get the login page). Are you still seeing the connection errors?

 

Your Sqoop command looks like everything is on one line, but with the backslashes still included. The backslashes are shown in the example to stop the line-breaks from ending the command. Perhaps try removing the backslashes and just running it as a single line?

 

e.g.

 

sqoop import-all-tables -m 12 --connect jdbc:mysql://eed77-cldramaster-01:3306/retail_db --username=retail_dba --password=cloudera --compression-codec=snappy --as-avrodatafile --warehouse-dir=/user/hive/warehouse

 

Let us know if that works for you - the command looks correct otherwise...

Announcements