Reply
Highlighted
Explorer
Posts: 21
Registered: ‎09-15-2017

Newbie, services not started in Cloudera Quickstart

[ Edited ]
I just installed Cloudera quickstart vm 5.12.0

 

I launched Cloudera Express from the Desktop

I can see Cloudera Manager but the servcies seemed stopped

 

I had one system health warning about "quickstart.cloudera" / "Clock Offset"

I tried to "Restart" all services. Got the message that all services started successfully.

 

Unfortunately, within a few seconds, all services show a red icon and I now have 4 health warnings...

 

  • HBase / HBase Master Health
  • HDFS / Namenode Health
  • YARN (MR2 included) / ResourceManager Health
  • quickstart Cloudera / Clock Offset

I am obvioulsy doing something wrong... but what?

 

Any idea?

 

Thanks

 

Eric

Explorer
Posts: 8
Registered: ‎02-11-2018

Re: Newbie, services not started in Cloudera Quickstart

Hello,

 

First make sure you configure the VM with a minimun of 8GB of RAM and 2 CPU cores.

 

Second, don't try to start all services. Start only the services you really need. In getting started page (http://quickstart.cloudera/#/tutorial/getting_started) you only need to start 5 services.

 

If you still have the same problem copy&paste here the health warning in order we can help you.

 

I had this problem some days ago, and I fixed it by stopping all services and starting only the ones I need to do the exercice. It this doesn't work try restarting the VM (Linux).

 

Regards

Explorer
Posts: 21
Registered: ‎09-15-2017

Re: Newbie, services not started in Cloudera Quickstart

[ Edited ]

I'd love to start some service... but everything seems to fail right now...

 

Tried to add an image below but I suspect it's no good...

Please use the link otherwise

 

All services failing

 

https://drive.google.com/open?id=17wsSviQ3v3ns0ueL5qPUZuNDimCOUMOg

 

One failure on the Hosts seems to be 

Process Status (

Cloudera Management Service Host Monitor quickstart

)
Feb 19, 9:54 AM PST

Test of whether the process state of this role is as expected.
Loading... This role's host has been out of contact with Cloudera Manager for too long.

 

Explorer
Posts: 21
Registered: ‎09-15-2017

Re: Newbie, services not started in Cloudera Quickstart

Would love to start ANY service...

 

https://drive.google.com/open?id=17wsSviQ3v3ns0ueL5qPUZuNDimCOUMOg

 

Health issue on the host service 

 

Process Status (

Cloudera Management Service Host Monitor quickstart

)
Feb 19, 9:54 AM PST

Test of whether the process state of this role is as expected.
Loading... This role's host has been out of contact with Cloudera Manager for too long.

 

Any idea?

 

Thanks

Explorer
Posts: 21
Registered: ‎09-15-2017

Re: Newbie, services not started in Cloudera Quickstart

I have tried to restart the machine and it looks better.

 

It looks like I allocated too much memory... which does not surprise me.

 

"quickstart.cloudera: Memory Overcommit Validation Threshold Suppress...
Memory on host quickstart.cloudera is overcommitted. The total memory allocation is 13.6 GiB bytes but there are only 7.7 GiB bytes of RAM (1.5 GiB bytes of which are reserved for the system). Visit the Resources tab on the Host page for allocation details. Reconfigure the roles on the host to lower the overall memory allocation. Note: Java maximum heap sizes are multiplied by 1.3 to approximate JVM overhead.

How would I get in lowering memory usage?"

 

I am quite happy to stop services I might have started by mistake...

 

https://drive.google.com/open?id=1VNz0RqEnQqB0XMjba4nUzghqlXxgEnkt

Explorer
Posts: 21
Registered: ‎09-15-2017

Re: Newbie, services not started in Cloudera Quickstart

I am 100% certain I had tried to restart the machine before... but this time it seems to work.

Just one critical error left on YARN

"Bad: This role's process exited. This role is supposed to be started"

 

Bizarre... 

Explorer
Posts: 21
Registered: ‎09-15-2017

Re: Newbie, services not started in Cloudera Quickstart

[ Edited ]

Actually, this virtual machine is extremely unstable...

 

I have relatively little time to experiment with it and every single time I look at it, something else is broken.

Of course I can reboot, but I thought it was a specialty of Windows... and it's never long before most services get warnings or even critical errors.

 

My laptop has only 16Gbs and I still need to use it for other tasks.

 

Is it that I don't give this virtual box enough memory?

 

I have allocated a bit more memory (just above 8Gbs), restarted and it's all green so far...

Fingers crossed

Explorer
Posts: 21
Registered: ‎09-15-2017

Re: Newbie, services not started in Cloudera Quickstart

Yet again, the services fail... 

2018-02-23_21-08-05 Configuration issue.jpg

Could someone tell me which services I could stop and how?

Each time I try to stop a service, it says it's being used by a few other services...

 

2018-02-23_21-10-17 services state (unknown).jpg

This is really frustrating!

 

 

Explorer
Posts: 21
Registered: ‎09-15-2017

Re: Newbie, services not started in Cloudera Quickstart

Tried to "restart stale services" and after quite a while they seem to be back to life...

 

2018-02-23_21-26-09 Hive came back for no apparent reason.jpg

 

It would be lovely if I could stop this thing from falling apart every few hours...

 

Any tip?

 

 

Thanks

 

PS: I have allocated 4cpus and about 9Gbs memory

 

Explorer
Posts: 21
Registered: ‎09-15-2017

Re: Newbie, services not started in Cloudera Quickstart

If anyone is interested...

 

It looks like the main secret is to let the box run for a couple of hours and the services seem to go back to green...

 

Maybe more of a monitoring issue rather than a real problem

Announcements