New Contributor
Posts: 1
Registered: ‎09-13-2013

Quickstart in virtualbox does not work


I ran quickstart vm on virtualbox and it worked for one day, but then for some reasons all services stopped working. Restart and full reimport (remove and import the vbox image) didn't help. The cloudera manager failed to start any service with the message:


Command aborted because of exception: Command timed-out after 150 seconds


In logs I see the repeated error:


2013-09-12 22:39:31,961  WARN [1224953372@scm-web-18:tsquery.TimeSeriesQueryService@503] com.cloudera.server.cmf.tsquery.TimeSeriesQueryService@2435968a failed to locate nozzleHOST_MONITORING

com.cloudera.cmon.MgmtServiceLocatorException: Could not find a HOST_MONITORING nozzle from SCM.

at com.cloudera.cmon.MgmtServiceLocator.getNozzleIPC(

at com.cloudera.server.cmf.tsquery.NozzleRequest.<init>(

at com.cloudera.server.cmf.tsquery.TimeSeriesMultiRequest.<init>(

at com.cloudera.server.cmf.tsquery.TimeSeriesQueryService.queryTimeSeries(

at com.cloudera.server.web.cmf.charts.TimeSeriesQueryController.queryTimeSeries(


I tried to run host upgrade, but it failed with the following message:


Loaded plugins: fastestmirror

Determining fastest mirrors

* base:

* epel:

* extras:

* updates: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404"

Trying other mirror.

Error: Cannot retrieve repository metadata (repomd.xml) for repository: cloudera-search. Please verify its path and try again

END (1)


Unfortunately I cannot install CDH through Cloudera manager as I use Mac os. It seems I will try to install manually from tar, but any way would like to notify you about these problems... May be there are some older working images of Quickstart?

Cloudera Employee
Posts: 435
Registered: ‎07-12-2013

Re: Quickstart in virtualbox does not work

The original error you're getting should not be causing any problems - continue checking the logs for other issues. Host monitoring is one of the services provided by Cloudera Manager, but since it is of little use on a pseuo-distributed cluster it is not enabled in the QuickStart VM to free up resources for other services.


If you want to upgrade (although again - it sounds like there's a different root cause here) - you can resolve the 404 error you're seeing by changing the file /etc/yum.repos.d/cloudera-search.repo. If you're not using Cloudera Search or Apache Solr, you can simply delete this file. Otherwise you can edit it and change any references from to (Search was recently released generally, and is no longer in Beta). An updated VM will be available soon without this problem, however I don't believe it has anything to do with why the services didn't start.


I would recommend starting with ZooKeeper (since it is a dependency for most other services). Try manually starting it in Cloudera Manager, and then checking it's logs if you run into any problems, and reporting back here.

Expert Contributor
Posts: 93
Registered: ‎09-17-2014

Re: Quickstart in virtualbox does not work

i got the same error,solved it by restarting the cloudera management services and it got working.