Reply
New Contributor
Posts: 2
Registered: ‎12-03-2015

Tutorial Exercise 4 - Permission denied

Hello,

 

While trying to create the collection in exercise 4, I'm getting this error: 

 

Unable to create core [live_logs_shard1_replica1] Caused by: Permission denied: user=solr, access=WRITE, inode="/":hdfs:supergroup:drwxr-xr-x

 

After executing the following command on a VMWare Quickstart:

 

[cloudera@quickstart flume]$ solrctl --zk quickstart:2181/solr collection --create live_logs -s 1

 

I already had a permission error during the Spark exercise 3, what am I doing wrong? 

 

Thank you

 

New Contributor
Posts: 3
Registered: ‎01-04-2016

Re: Tutorial Exercise 4 - Permission denied

Had the same problem today. Just downloaded the quick start VM earlier this evening.
Highlighted
Explorer
Posts: 6
Registered: ‎01-23-2016

Re: Tutorial Exercise 4 - Permission denied

[ Edited ]

Same problem. Tried adding user "solr" to the supergroup but that didn't work either.

 

--Fixed by creating /user/solr in hdfs and chown the perms solr:solr in hadoop

New Contributor
Posts: 3
Registered: ‎01-19-2016

Re: Tutorial Exercise 4 - Permission denied

Same problem here.

 

Tried BobBobsonIIIEsq solution, but still get the same problem.

 

Help would be really, really appreciated!

New Contributor
Posts: 4
Registered: ‎01-04-2016

Re: Tutorial Exercise 4 - Permission denied

Try this:

 

The error message states the 'solr' user is denied permission to write the collection directly to root directory. If you are using Cloudera Manager, try verifying configuration settings and check the HDFS data directory path, /solr or /user/solr.

 

Capture.PNG

 

If the path is set to /solr, then use hdfs to create the directory and chown it to solr

 

bash-4.1$ hadoop fs -mkdir /solr
bash-4.1$ hadoop fs -chown -R solr:solr /solr

Thanks for the friend who showed this fix.

New Contributor
Posts: 1
Registered: ‎05-06-2016

Re: Tutorial Exercise 4 - Permission denied

Thanks. I have to use "sudo -u hdfs hadoop fs -mkdir /solr" and "sudo -u hdfs hadoop fs -chown -R solr:solr /solr" to make it work.