Reply
Highlighted
New Contributor
Posts: 2
Registered: ‎08-23-2016

install impala-kudu

[ Edited ]

HI! I'm trying to install impala-kudu in my CentOS OS. but request a another component libsasl2.so.2()(64bit). then i exec yum -y install cyrus-sasl-lib comand to try fix this problem, but it didn't work. following is error messages; [root@server4 ~]# yum install impala-kudu Loaded plugins: fastestmirror, langpacks Repository base is listed more than once in the configuration base | 3.6 kB 00:00:00 cloudera-cdh5 | 2.9 kB 00:00:00 extras | 3.4 kB 00:00:00 updates | 3.4 kB 00:00:00 Loading mirror speeds from cached hostfile * base: mirrors.btte.net * extras: mirrors.tuna.tsinghua.edu.cn * updates: mirrors.tuna.tsinghua.edu.cn Resolving Dependencies --> Running transaction check ---> Package impala-kudu.x86_64 0:2.7.0+cdh5.9.0+0-1.cdh5.9.0.p0.109.el6 will be installed --> Processing Dependency: libsasl2.so.2()(64bit) for package: impala-kudu-2.7.0+cdh5.9.0+0-1.cdh5.9.0.p0.109.el6.x86_64 --> Finished Dependency Resolution Error: Package: impala-kudu-2.7.0+cdh5.9.0+0-1.cdh5.9.0.p0.109.el6.x86_64 (cloudera-cdh5) Requires: libsasl2.so.2()(64bit) You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest [root@server4 ~]# cd / [root@server4 /]# find / -name libsasl2.so.2 [root@server4 /]# yum -y install cyrus-sasl-lib Loaded plugins: fastestmirror, langpacks Repository base is listed more than once in the configuration Loading mirror speeds from cached hostfile * base: mirrors.btte.net * extras: mirrors.tuna.tsinghua.edu.cn * updates: mirrors.tuna.tsinghua.edu.cn Package cyrus-sasl-lib-2.1.26-20.el7_2.x86_64 already installed and latest version Nothing to do

New Contributor
Posts: 2
Registered: ‎08-23-2016

Re: install impala-kudu

I've solved this problem. The key reason is sasl version requested by impala-kudu is different from existed in my system. I have libsasl2.so.3 in my /usr/lib64 but libsasl2.so.2 is requested by impala-kudu. so, the resoloved method is uninstall libsasl2.so.3 and reinstall libsasl2.so.2.