Reply
New Contributor
Posts: 1
Registered: ‎01-17-2015

invalidate metadata - error

 

Receiving the following error while following tutorial 2 :

------------------------------------------------------------------ 

analysisexception: syntax error in line 1: use ^ encountered: eof expected: identifier caused by: exception: syntax error

 

------------------------------------------------------------------

 

This error occurs after successfully going through tutorial 1 steps. please help.

 

 

New Contributor
Posts: 1
Registered: ‎06-15-2015

Re: invalidate metadata - error

I am also having the same issue. Can any one please provide me a fix for it. I get the above error wheneve I type in anything. How do I verify if it is connected to the database?

Cloudera Employee
Posts: 435
Registered: ‎07-12-2013

Re: invalidate metadata - error

There's not really a lot of information here to figure out what the problem is and I cannot reproduce it, so forgive the massive amount of questions but there's no other good place to start:

 

- A previous step should have directed you to check that Impala and several other services were running and marked in green in Cloudera Manager. Can you re-check?

- The home page in Hue should show a warning in red if it can't connect to Impala. The home page is ....:8888/about, or you can click on the logo, or just log in again). Can you check for any such error?

 

If that fails to provide any clues, I'd check the behavior in the Hive Query Editor app as well, and in the 'hive' shell again. 'show tables;' would be a good one to run - it should show all 6 tables: categories, customers, departments, order_items, orders, products. Also try in the 'impala-shell' tool on command-line. Run 'impala-shell -i cldraagent-01', and then try the 'show tables;' query. That should narrow down if the issue is something in Hue, or in the Hive metastore or in Impala...

 

New Contributor
Posts: 1
Registered: ‎01-24-2016

Re: invalidate metadata - error

I configured impala configuration file with statestore_subscriber_timeout_seconds=300 restaretd services and it worked.

Explorer
Posts: 9
Registered: ‎02-24-2015

Re: invalidate metadata - error

Please forgive the dual post. I am having the same issue. I've tried all remedies suggested by the Google.

 

I posted a topic in a different forum, possibly the wrong place (?). Link is: https://community.cloudera.com/t5/Apache-Hadoop-Concepts-and/Hue-Impala-failing-for-all-queries/m-p/...

 

 

Text of the other post follows:

I've been working with the CDH 5.5.0 VM for a couple of weeks.

* I started Tutorial number two.

* Loaded the data.

*Created the tables (in Hive).

* Now trying to use Hue Impala to query the tables.

 

Something happened in Hue such that Impala can't seem to load the metadata. In the database frame on the left side it says "The database list cannot be loaded." All Impala queries, even invalidate metadata, return the following error message:

AnalysisException: Syntax error in line 1: USE `` ^ Encountered: EMPTY IDENTIFIER Expected: IDENTIFIER CAUSED BY: Exception: Syntax error

 

impala-shell works fine for all queries and commands. It is only Hue that is having the issue.

 

I have done the following:

Run invalidate metadata in impala-shell (works fine)

Restarted Hue

Restarte Impala

Restarted the VM several times

 

This guy is having the same issue:

http://stackoverflow.com/questions/35018518/impala-query-editor-always-shows-analysisexception

 

Any help would be appreciated as I'm working on a POC to get approval for purchasing Cloudera.

Thanks all!

Highlighted
New Contributor
Posts: 2
Registered: ‎05-01-2016

Re: invalidate metadata - error

sudo service hive-server2 restart

 restarting hive by running above command worked for me.