Reply
Highlighted
New Contributor
Posts: 3
Registered: ‎09-25-2015

"Hadoop fs -ls" produces connection exception

I have started all cloudera services and when I run "hadoop fs -ls" I get the following connection exception message. What could be wrong here ?

 

 

[cloudera@quickstart /]$ hadoop fs -ls
ls: Call From quickstart.cloudera/10.0.2.15 to quickstart.cloudera:8020 failed on connection exception: java.net.ConnectException: Connection refused; For more details see:  http://wiki.apache.org/hadoop/ConnectionRefused

Cloudera Employee Sue
Cloudera Employee
Posts: 44
Registered: ‎09-11-2015

Re: "Hadoop fs -ls" produces connection exception

I just downloaded the latest Cloudera Quickstart VM to test your command (I am using VMWare, and the VM is running CDH 5.4.2).

 

I didn't receive an error - screenshot is included below.

Try to verify that the zip file you downloaded was complete (check the size and md5 checksum).

 

You can also issue the 'sudo jps' command and verify that the services are running (I did not have to start any services - I just booted the VM and opened a terminal window within the VM). You can see the results of my 'sudo jps' command

in the screenshot below.

 

 

 Screen Shot 2015-10-03 at 4.36.07 PM.png

 

 

New Contributor
Posts: 1
Registered: ‎12-13-2015

Re: "Hadoop fs -ls" produces connection exception

It works until you reboot the VM. I see the same error