Reply
New Contributor
Posts: 1
Registered: ‎03-11-2015

unable to Ssh using putty from windows to cloudera-quickstart-vm-4.7.0-0-vmware running vmplayer 7

unable to Ssh using putty from windows to cloudera-quickstart-vm-4.7.0-0-vmware running vmplayer 7.

 

I can see ssh running fine

netstat -anp | grep ssh
tcp 0 0 127.0.0.1:22 0.0.0.0:* LISTEN 18763/sshd
tcp 0 0 192.168.207.128:22 0.0.0.0:* LISTEN 18763/sshd

 

Also removed iptables

 

error message connection refused.

 

 

Greatly appreciate help

 

New Contributor
Posts: 7
Registered: ‎03-13-2015

Re: unable to Ssh using putty from windows to cloudera-quickstart-vm-4.7.0-0-vmware running vmplayer

Had the same problem with the VirtualBox VM.

 

Basically could not ping the VM from my host.

 

Resolution in VirtualBox was to add a second network adaptor for the VM.  I believe that using Bridged networking as opposed to NAT would also work, but this was easy and it allowed the Host to ping the guest.

 

This video shows how to do it for VirtualBox: https://www.youtube.com/watch?v=AhSNj7s5Fko

 

Hope this helps.

 

Morgan

How to enable IP address for Cloudera VM ▶ For Best USB MicroPhone I use Yeti, check it out https://amzn.to/2GTjz6K ▶ Check out my list of recommended books on Hadoop/Spark/Storm/DataScience/Kafka/Cassandra/Mongodb -- http://bit.ly/2FaP1MF ***** ▶ Check out my selection of books on ...
Expert Contributor
Posts: 61
Registered: ‎03-06-2015

Re: unable to Ssh using putty from windows to cloudera-quickstart-vm-4.7.0-0-vmware running vmplayer

Enabling port 22 in iptables worked for me.

 

Just open port 22 and make sure ssh is configured with 22 and sshd service started.

 

 

New Contributor
Posts: 1
Registered: ‎10-14-2016

Re: unable to Ssh using putty from windows to cloudera-quickstart-vm-4.7.0-0-vmware running vmplayer

just set second network as bridge mode. works great CDH 5.8.0

New Contributor
Posts: 3
Registered: ‎01-31-2019

Re: unable to Ssh using putty from windows to cloudera-quickstart-vm-4.7.0-0-vmware running vmplayer

[ Edited ]

try to ping on that ip first (127.0.0.1 or for my case I had to add another bridge ip)
suits well with port 22 as mentioned in @nauseous the port 22 sould be enabled in iptables (firewall) , and so for ssh ( /etc/ssh/sshd_config) check if the port is still commented with # (that means still on default port 22 )
otherwise try to add a new port of your own .

Highlighted
New Contributor
Posts: 3
Registered: ‎02-17-2019

Re: unable to Ssh using putty from windows to cloudera-quickstart-vm-4.7.0-0-vmware running vmplayer

With VM powered down

 

  1. Right-click your virtual machine, select "Settings", and then select "Network".
  2. Next to "Attached to", select "Host-only Adapter". As a side note, "Bridged Adapter" will also work, check the VirtualBox documentation for more details about each option.