Reply
Highlighted
New Contributor
Posts: 3
Registered: ‎01-31-2018

Cloudera ODBC Driver for Impala

I am trying to configure the Cloudera ODBC Driver for Impala on a Mac. The instructions state that you need to set the DYLD_LIBRARY_PATH to the location of the iODBC libraries. The issue is that with the later OS X versions, setting DYLD_LIBRARY_PATH or LD_LIBRARY_PATH is prohibited by System Integrity Protection. 

 

The trace error we get is: 

 

Jan 31 11:11:09 INFO  1 ConnectionAttributes::SetAttribute: Invalid attribute: 1051

Jan 31 11:11:09 ERROR 1 Connection::SQLSetConnectAttr: [Cloudera][ODBC] (10210) Attribute identifier invalid or not supported: 1051

Jan 31 11:11:09 TRACE 1 CInterface::SQLDriverConnectW: +++++ enter +++++

Jan 31 11:11:09 TRACE 1 Connection::SQLDriverConnectW: +++++ enter +++++

Jan 31 11:11:09 TRACE 1 ConnectionState2::SQLDriverConnectW: +++++ enter +++++

Jan 31 11:11:09 ERROR 1 Connection::SQLDriverConnectW: [Cloudera][ODBC] (10360) Invalid connection string.

 

I found this in an earlier issue, and it said the solution was to set the DYLD_LIBRARY_PATH (but now this is no longer possible).

 

Is the driver searching for that specific variable? 

 

I have the required libraries in: /usr/local/lib

 

That should be at the front of the runtime search path for libraries. I also tried modifying the clouder.impala.odbc.ini file with the library name, a specific name that has the version in it, and still no luck. We tried including the path to the file as well.

 

ODBCInstLib=libiodbcinst.3.52.dylib

 

Please let me know if there is a fix for this, or possibly a later version of the driver.

 

FYI, we have been able to make UnixODBC work on a Mac, just not iODBC, and we need iODBC to support Microsoft Excel.

 

Thanks,

 

Cory