Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 06-18-2018 06:30 AM - edited 09-16-2022 06:21 AM
After upgrade Cloudera Manager from 5.14.0 to 5.15.0 my trusted_subnets in KUDU configuration does not work. Also --trusted_subnets=0.0.0.0/0 does not work. I get an error in the impala-shell :
ERROR: TransmitData() to x.x.x.x:27000 failed: Not authorized: Client connection negotiation failed: client connection to x.x.x.x:27000: FATAL_UNAUTHORIZED: Not authorized: unencrypted connections from publicly routable IPs are prohibited. See --trusted_subnets flag for more information.: x.x.x.x:52167
My config is:
--trusted_subnets=0.0.0.0/0
--rpc-authentication=disabled
--rpc-encryption=disabled
Created 06-18-2018 10:27 AM
Hi @buddelflinktier,
Impala has started using KRPC for the TransmitData() RPC as well from 5.15. So you would need to configure the 'trusted_subnets' flag the same way in your Impala configuration as well (it doesn't pick it up from the Kudu configuration).
- Sailesh
Created 06-18-2018 10:27 AM
Hi @buddelflinktier,
Impala has started using KRPC for the TransmitData() RPC as well from 5.15. So you would need to configure the 'trusted_subnets' flag the same way in your Impala configuration as well (it doesn't pick it up from the Kudu configuration).
- Sailesh
Created 06-18-2018 03:05 PM
Thanks, it works fine!