Reply
Highlighted
Contributor
Posts: 49
Registered: ‎07-26-2016

R with Cloudera Impala Connection error ?

Hi Team,

 

I am having a Quickstart VMware Cloudera 5.8 System.

In that I have installed R and R studio.

I want to integrate R and Imapala.

 

For that i done the below steps :

 

$ sudo yum install unixODBC
$ sudo yum install unixODBC-devel
$ yum --nogpgcheck localinstall ClouderaImpalaODBC-2.5.5.1005-1.el6.x86_64.rpm

And copied the  odbc.ini and cloudera.impalaodbc.ini files to the path = /etc/

odbc.ini

HOST=quickstart.cloudera
PORT=21050
Database=default

 cloudera.impalaodbc.ini

# SimbaDN / unixODBC
ODBCInstLib=libodbcinst.so

 In addition  I  defined the environment variables as follows:

$ export LD_LIBRARY_PATH=/usr/local/lib:/opt/cloudera/impalaodbc/lib/64
$ export ODBCINI=/etc/odbc.ini
$ export SIMBADN=/etc/cloudera.impalaodbc.ini

 After that I opened R console and Packages installation done.

$ R
>install.packages("RODBC")

 I am facing below error, while connecting Impala.

 

2017-05-30_1026.png

 

Please guide to sort this issue.

 

Thanks,

Syam.

Posts: 642
Topics: 3
Kudos: 119
Solutions: 67
Registered: ‎08-16-2016

Re: R with Cloudera Impala Connection error ?

You need to add a DSN to the odbc.ini file. Check out this link to get you going. It has an example DSN listed. It seems like you just need to add the label in front of the settings you already have, like this [Impala]. Don't forget to add the Driver setting as well.

https://www.cloudera.com/documentation/enterprise/5-6-x/topics/impala_odbc.html