Reply
Highlighted
DBA
New Contributor
Posts: 1
Registered: ‎09-03-2018

[S1000][unixODBC][Cloudera][ThriftExtension] (5) Error occurred while contacting server:

Hi Gurus

 

After configuring the Unix ODBC and Cloudera IMPALA ODBC on a 64 bit machine i am getting the below error.

 

[S1000][unixODBC][Cloudera][ThriftExtension] (5) Error occurred while contacting server: No more data to read.. This could be because you are trying to establish a non-SSL connection to a SSL-enabled server.

 

[oracle@jabdl3311 ~]$ odbcinst --version
unixODBC 2.2.11

[oracle@jabdl3311 ~]$ rpm -qa | grep ClouderaImpalaODBC
ClouderaImpalaODBC-2.5.42.1031-1

 

[oracle@jabdl3311 ~]$ odbcinst -j
unixODBC 2.2.11
DRIVERS............: /auto/oracle-8.0.6/odbcinst.ini
SYSTEM DATA SOURCES: /auto/oracle-8.0.6/odbc.ini
USER DATA SOURCES..: /auto/oracle-8.0.6/odbc.ini

[oracle@jabdl3311 ~]$ odbcinst -j
unixODBC 2.2.11
DRIVERS............: /auto/oracle-8.0.6/odbcinst.ini
SYSTEM DATA SOURCES: /auto/oracle-8.0.6/odbc.ini
USER DATA SOURCES..: /auto/oracle-8.0.6/odbc.ini
[oracle@jabdl3311 ~]$ cat /auto/oracle-8.0.6/odbc.ini
[IMPLDSN]
Description=Cloudera ODBC Driver for Impala (64-bit) DSN
Driver=/opt/cloudera/impalaodbc/lib/64/libclouderaimpalaodbc64.so
#Driver=IMPLDSN
HOST=161.194.218.120
#HOST=IMPLDSN
PORT=21050
Database=h011bsl_rws
AuthMech=0
SSL=0
#locale=en-US
#UID=cloudera
TrustedCerts=/opt/cloudera/impalaodbc/lib/64/cacerts.pem
EnableQuotedIdentifiers=1

 

[oracle@jabdl3311 ~]$ cat /auto/oracle-8.0.6/odbcinst.ini
# Example driver definitions

# See /usr/share/doc/unixODBC*/README.64bit for more information

# Use these definitions with the original unixODBC package

# Driver from the postgresql-odbc package
# Setup from the unixODBC-libs package
[IMPLDSNDriver]
Description     = Cloudera ODBC Driver for Impala (64-bit) DSN
Driver          = /opt/cloudera/impalaodbc/lib/64/libclouderaimpalaodbc64.so

 

[oracle@jabdl3311 ~]$ cat cloudera.impalaodbc.ini
[Driver]
#DriverManagerEncoding=UTF-32
ODBCInstLib=/usr/lib64/libodbc.so
ErrorMessagesPath=/opt/cloudera/impalaodbc/ErrorMessages/
LogLevel=0
LogPath=
SwapFilePath=/tmp
[oracle@jabdl3311 ~]$


/dbsld9/bsl/oracle/rdbms/gateway/hs/admin
[oracle@jabdl3311 admin]$ cat initIMPLDSN.ora
# This is a sample agent init file that contains the HS parameters that are
# needed for the Database Gateway for ODBC

#
# HS init parameters
#
HS_FDS_CONNECT_INFO=IMPLDSN
#HS_FDS_TRACE_LEVEL=0
#HS_FDS_SHAREABLE_NAME=/opt/cloudera/impalaodbc/lib/64/libclouderaimpalaodbc64.so
HS_FDS_SHAREABLE_NAME=/usr/lib64/libodbc.so
HS_TRANSACTION_MODEL=READ_ONLY_AUTOCOMMIT
HS_NLS_NCHAR=UCS2
HS_LANGUAGE=AMERICAN_AMERICA.WE8ISO8859P1
HS_FDS_SUPPORT_STATISTICS=FALSE
HS_FDS_TRACE_LEVEL=4
HS_FDS_TRACE_FILE_NAME=/tmp/hsodbccloudera.trc
HS_FDS_TRACE_LEVEL=Debug
#
# ODBC specific environment variables
#
set ODBCINI=/auto/oracle-8.0.6/odbc.ini
set ODBCINSTINI=/auto/oracle-8.0.6/odbcinst.ini
set ODBCSYSINI=/auto/oracle-8.0.6
set CLOUDERAIMPALAODBCINI=/auto/oracle-8.0.6/cloudera.impalaodbc.ini
set LD_LIBRARY_PATH=/usr/lib64
[oracle@jabdl3311 admin]$

 

 

Pls. help me to get rid of this issue.

 

Thanks & Regards

Anish

Cloudera Employee
Posts: 818
Registered: ‎03-23-2015

Re: [S1000][unixODBC][Cloudera][ThriftExtension] (5) Error occurred while contacting server:

The error message might mean that your Impala on the server side has SSL enabled, but client was set as SSL=0. Can you please confirm if that is the case?