New Contributor
Posts: 2
Registered: ‎03-21-2018

Unable to pass parameter to Impala from SSRS

I am working on a poc where I have to connect my ssrs report to fetch data from impala based on the user selection made and display it in report. To get the required data , i have created a dataset , connected it to Impala data source , and passed argument. But it is not working out.


sample query :

Select * from table

where user_selection=@param


Here 'param' is defined under parameter folder of SSRS report and also pointing in the current dataset.

also , instead of @ - I have tried :param,?param,${param},[param],[@param] and many more ... but nothing worked out.


Please let me know your thoughts.


PS : I have posted the same on SSRS forum as well.

Cloudera Employee
Posts: 437
Registered: ‎07-29-2015

Re: Unable to pass parameter to Impala from SSRS

Hi @Impala_issues,

  I think this is more of an SSRS question than an Impala question, although there may be people on this forum using Impala in a similar way.


I'm assuming that SSRS uses the Impala ODBC driver. The Impala ODBC driver supports the standard SQLBindParameter() API to subsitute ? in the query text with parameters. I have no idea if SSRS has some kind of additional parameter substitution logic on top of that.




New Contributor
Posts: 1
Registered: ‎04-01-2018

Re: Unable to pass parameter to Impala from SSRS

Hi @Impala_issues , 


I'm facing the same issue here.

Have you tried other alternatives?

I also need some suggestions.


Many thanks!