Reply
Highlighted
Explorer
Posts: 15
Registered: ‎08-04-2017

impala-shell failed to launch on Oracle Linux 7.X with python 2.7.5 on edge node

Team,

 

My cluster uses CDH5.13.1 on Oracle linux 6.9 which uses base python 2.6.6. On my edge nodes with Oracle Linux 6.9 running with python 2.6.6 does not have any issues in launching impala-shell.

 

I have built an edge node on Oracle linux 7.x that comes with python 2.7.5 which is causing issues for launching impala-shell.

 

Please refer to below error and suggest for any possible solutions. 

 

impala-shell -k --ssl -i <impalahost>
/opt/cloudera/parcels/CDH-5.13.1-1.cdh5.13.1.p0.2/lib/impala-shell/ext-py/sasl-0.1.1-py2.6-linux-x86_64.egg/_saslwrapper.py:3: UserWarning: Module backports was alreadyaconda2/lib/python2.7/site-packages is being added to sys.path
Traceback (most recent call last):
File "/opt/cloudera/parcels/CDH-5.13.1-1.cdh5.13.1.p0.2/bin/../lib/impala-shell/impala_shell.py", line 38, in <module>
from impala_client import (ImpalaClient, DisconnectedException, QueryStateException,
File "/opt/cloudera/parcels/CDH-5.13.1-1.cdh5.13.1.p0.2/lib/impala-shell/lib/impala_client.py", line 20, in <module>
import sasl
File "/opt/cloudera/parcels/CDH-5.13.1-1.cdh5.13.1.p0.2/lib/impala-shell/ext-py/sasl-0.1.1-py2.6-linux-x86_64.egg/sasl/__init__.py", line 1, in <module>

File "/opt/cloudera/parcels/CDH-5.13.1-1.cdh5.13.1.p0.2/lib/impala-shell/ext-py/sasl-0.1.1-py2.6-linux-x86_64.egg/sasl/saslwrapper.py", line 7, in <module>
File "/opt/cloudera/parcels/CDH-5.13.1-1.cdh5.13.1.p0.2/lib/impala-shell/ext-py/sasl-0.1.1-py2.6-linux-x86_64.egg/_saslwrapper.py", line 7, in <module>
File "/opt/cloudera/parcels/CDH-5.13.1-1.cdh5.13.1.p0.2/lib/impala-shell/ext-py/sasl-0.1.1-py2.6-linux-x86_64.egg/_saslwrapper.py", line 6, in __bootstrap__
ImportError: libsasl2.so.2: cannot open shared object file: No such file or director

 

Thanks,

Meher

Announcements