Reply
New Contributor
Posts: 1
Registered: ‎04-02-2016

ERROR: Can't get master address from ZooKeeper; znode data == null

Hi All,

 

I'm new to this hadoop world. I'm stuck with a problem here hope to get a valuable resolution from this forum.

 

Objective : To create a simple table on hbase using hbase shell.

 

Observation :  When I type create 'mytab',  'add' ,  'order'  and  press enter on hbase shell. I get this error "ERROR: Can't get master address from ZooKeeper; znode data == null". 

To check the services I ran service --status-all | grep FAILED. The following result was displayed :

Flume NG agent is not running [FAILED]
Hadoop proxyserver is dead and pid file exists [FAILED]
HBase master daemon is dead and pid file exists [FAILED]
HBase Solr Indexer is not running [FAILED]
Sentry DB Store Service is dead and pid file exists [FAILED]

To start the Hbase master I ran the command sudo service hbase-master start

It displayed the result as ok. However, when I check the status of the hbase master again it shows me Failed. 

 

Details: I'm using CDH 5.5.0 on virtual box.

Hbase site.xml :

<configuration>
<property>
<name>hbase.rest.port</name>
<value>8070</value>
<description>The port for the HBase REST server.</description>
</property>

<property>
<name>hbase.cluster.distributed</name>
<value>true</value>
</property>

<property>
<name>hbase.rootdir</name>
<value>hdfs://quickstart.cloudera:8020/hbase</value>
</property>

<property>
<name>hbase.regionserver.ipc.address</name>
<value>0.0.0.0</value>
</property>

<property>
<name>hbase.master.ipc.address</name>
<value>0.0.0.0</value>
</property>

<property>
<name>hbase.thrift.info.bindAddress</name>
<value>0.0.0.0</value>
</property>

</configuration>

 

Can anyone please suggest what is causing this problem.

 

Thanks and regards,

Santos

Expert Contributor
Posts: 101
Registered: ‎01-24-2014

Re: ERROR: Can't get master address from ZooKeeper; znode data == null

A bit late, but maybe helpful for future searchers. 

 

Sounds like HBase has failed to initialize. 

 

I would advise first checking the hbase master logs for any helpful clues.

 

Based on your desciption, Zookeeper has no master znode because HMaster isn't running. I would guess that either HDFS is in safe mode or not running, which in turn means Hbase cannot start up.