Reply
New Contributor
Posts: 2
Registered: ‎02-09-2016

I am getting an api error when accessing hbase browser through hue?

hi everyone,

 

when I try to access hbase browser through hue, I am getting following error

 

Api Error: Error 500 User: hbase is not allowed to impersonate cloudera HTTP ERROR 500 Problem accessing /. Reason: User: hbase is not allowed to impersonate clouderaCaused by:javax.servlet.ServletException: User: hbase is not allowed to impersonate cloudera at org.apache.hadoop.hbase.thrift.ThriftHttpServlet.doPost(ThriftHttpServlet.java:117) at javax.servlet.http.HttpServlet.service(HttpServlet.java:727) at javax.servlet.http.HttpServlet.service(HttpServlet.java:820) at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:511) at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:401) at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:182) at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:767) at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152) at org.mortbay.jetty.Server.handle(Server.java:326) at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:542) at org.mortbay.jetty.HttpConnection$RequestHandler.content(HttpConnection.java:945)

 

http://www.cloudera.com/documentation/enterprise/5-3-x/topics/cm_rn_known_issues.html

 

I followed this link but didn't get any solution.

I'm new in this,if anyone have solution regarding this please post a reply.

 

Champion Alumni
Posts: 196
Registered: ‎11-18-2014

Re: I am getting an api error when accessing hbase browser through hue?

Hello,

 

Please check: http://gethue.com/hbase-browsing-with-doas-impersonation-and-kerberos/

 

"This error means that the above ‘hadoop.proxyuser.hbase.hosts’ / ‘hadoop.proxyuser.hbase.groups’ properties are not correct:"

 

The default configuration for these 2 properties:

hadoop.proxyuser.hbase.host = *
hadoop.proxyuser.hbase.groups = *

Hoping that this will help you,

 

 

GHERMAN Alina
New Contributor
Posts: 2
Registered: ‎02-09-2016

Re: I am getting an api error when accessing hbase browser through hue?

[ Edited ]

thank you GHERMAN Alina for your reply

but I'm still getting the same problem.Is there any other way?

Highlighted
Champion Alumni
Posts: 196
Registered: ‎11-18-2014

Re: I am getting an api error when accessing hbase browser through hue?

Hi,

 

I think this may also happen if you don't have the hbase impersonalisation enabled:

Hopes this helps,

 

 

GHERMAN Alina