Reply
Cloudera Employee
Posts: 16
Registered: ‎10-03-2017

Re: ERROR: Found inconsistency in table SYSTEM.CATALOG

Hello Vinod,

 

Please refer to the previously mentioned hbck guide[1] or review the Appendix C[2] which is referenced at the end of that documentation that further discusses usage of hbck.

 

Generally near every hbck troubleshooting is best begin with a single

$ sudo -u hbase hbase hbck -fixAssignments

As this will try to assign all regions that are not deployed at the time of the running. Holes can be present by many different reasons, the first step is reviewing if every region is assigned successfully, would the hole persist. Reassigning regions successfully usually eliminates the holes in the region chain.

 

It's also a good practice to see if the Apache HBase "thebook" has any information about the issue at hand. As CDH5.8+ uses HBase 1.2 it's best to check out the corresponding version of the Apache Documentation on HBase[3]. If you would have CDH6.0.x then it's best to review HBase 2.0's documentation of the same[4] which has hbck2.

 

[1] - Checking and Repiring HBase tables CDH5.15.x - https://www.cloudera.com/documentation/enterprise/5-15-x/topics/admin_hbase_hbck.html

[2] - Apache HBase documentation v1.2 / Appendix C - http://hbase.apache.org/1.2/book.html#hbck.in.depth

[3] - Apache HBase documentation v1.2 / HBase hbck - http://hbase.apache.org/1.2/book.html#hbck

[4] - Apache HBase documentation / HBase HBCK2 - http://hbase.apache.org/book.html#HBCK2

Highlighted
Explorer
Posts: 19
Registered: ‎11-08-2018

Re: hbase hbck reports inconsistency immediately after adding hbase service

Hello,

 

Thanks for your responce, Where ever i am checking the HBCK on that particular server we have HBase master role and from Gateway node also i can see same error.

 

Any other suggessions wolud be appriciated.

 

Thanks.