Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

403 Forbidden error on HDP 3.1.0 installation AWS

403 Forbidden error on HDP 3.1.0 installation AWS

New Contributor

On the AWS private cloud, we have 3 nodes master, edge data


We have installed Ambari 2.7.3 (HDP 3.1.0) on master node.


Environment variables for Ambari are in "/var/lib/ambari-server/ambari-env.sh" as:


export AMBARI_JVM_ARGS="$AMBARI_JVM_ARGS -Xms512m -Xmx2048m -XX:MaxPermSize=128m -Djava.security.auth.login.config=$ROOT/etc/ambari-server/conf/krb5JAASLogin.conf -Djava.security.krb5.conf=/etc/krb5.conf -Djavax.security.auth.useSubjectCredsOnly=false -Dcom.sun.jndi.ldap.connect.pool.protocol=\"plain ssl\" -Dcom.sun.jndi.ldap.connect.pool.maxsize=20 -Dcom.sun.jndi.ldap.connect.pool.timeout=300000 -Dhttp.proxyHost=proxy.server -Dhttp.proxyPort=3128 -Dhttp.nonProxyHosts=[localhost\|master-dev.fqdn]"



To install the remaining repository is via Ambari Console (Web UI).


There we have an option called "public repository" where the Ambari server gets all the packages from Hortonworks site and install them. During this install wizard, when we proceed to the next steps giving Database config detail for Ambari server to use MySQL, the Ambari Agent (running on the same host) is trying to download a file named "DBConnectionVerification.jar" from the Ambari server (same host), and failing with an error " Check network access to Ambari Server.\\nHTTP Error 403: Forbidden".


So, to address this we have changed the config to remove proxy, and use local repository.


export AMBARI_JVM_ARGS="$AMBARI_JVM_ARGS -Xms512m -Xmx2048m -XX:MaxPermSize=128m -Djava.security.auth.login.config=$ROOT/etc/ambari-server/conf/krb5JAASLogin.conf -Djava.security.krb5.conf=/etc/krb5.conf -Djavax.security.auth.useSubjectCredsOnly=false -Dcom.sun.jndi.ldap.connect.pool.protocol=\"plain ssl\" -Dcom.sun.jndi.ldap.connect.pool.maxsize=20 -Dcom.sun.jndi.ldap.connect.pool.timeout=300000"


However, with this option also, we are getting same 403 error.


We have tried to mimic this on shell.


wget http://master-dev.fqdn:8080/resources/DBConnectionVerification.jar is giving the same error "ERROR 403: Forbidden".


However, this wget is working fine without proxy.


wget http://master-dev.fqdn:8080/resources/DBConnectionVerification.jar --no-proxy


Anyone faced similar issue, who can suggest me of any resolutions please?

Don't have an account?
Coming from Hortonworks? Activate your account here