Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 03-14-2019 01:36 AM - edited 08-17-2019 04:44 PM
Hi all, i was able to to login yesterday but when im trying to login today i'm facing this issue.
Here is the output of ambari-server status from terminal
Screen Shot of /var/log/ambari-server
Also, here i attach the amabri-server.log ambari-server.txt
Any help is appreciated a lot. Thanks in advance
Created 03-14-2019 01:44 AM
The following kind of message indicates some filesystem issue:
Unable to access /var/log/ambari-server directory. Confirm the directory is created and is writable by Ambari Server user account 'root'
.
So please check if you have the mentioned directory created and you are able to create some dummy files inside that dir.
# echo "Test" > /var/log/ambari-server/test.log # mkdir -p /var/log/ambari-server/one
Check if somehow the "/var/log" filesystem has become read-only by any chance? May be rebooting the host will help in such cases.
Also please check if the file "ambari.properties" is showing correct username there:
# grep 'ambari-server.user' /etc/ambari-server/conf/ambari.properties ambari-server.user=root
.
Created 03-14-2019 01:44 AM
The following kind of message indicates some filesystem issue:
Unable to access /var/log/ambari-server directory. Confirm the directory is created and is writable by Ambari Server user account 'root'
.
So please check if you have the mentioned directory created and you are able to create some dummy files inside that dir.
# echo "Test" > /var/log/ambari-server/test.log # mkdir -p /var/log/ambari-server/one
Check if somehow the "/var/log" filesystem has become read-only by any chance? May be rebooting the host will help in such cases.
Also please check if the file "ambari.properties" is showing correct username there:
# grep 'ambari-server.user' /etc/ambari-server/conf/ambari.properties ambari-server.user=root
.
Created 03-14-2019 01:47 AM
Ambari simply makes the following Python call to check if it is able to create directories inside the failing directory with 0755 permission or not?
https://github.com/apache/ambari/blob/release-2.7.3/ambari-server/src/main/python/ambari_server/serv...
Created 03-14-2019 10:35 PM
Hey Thanks alot @Jay Kumar SenSharma it did work after reboot. But Now i'm facing different issue HST agent is redirecting to fail mode after restart. can you please help on this.