Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

API POST Error when Configuring Kerberos through wizard

Solved Go to solution

API POST Error when Configuring Kerberos through wizard

New Contributor

I am trying to enable Kerberos for my HDP-2.5 cluster. I have been following through the documentation but on the 'Install and Test Kerberos' the test is failing with the error shown below.

14061-kerberoserror.png

I am using an existing MIT KDC which I have installed on a separate box, and the JCE was unzipped for each host in the cluster.

The KDC connection was ok and I can't seem to find any other people with the same issue. Recently SSL was added to Ambari unsure if this is related. I have tried restarting the Kadmin server but with no avail.

Any help is much appreciated.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: API POST Error when Configuring Kerberos through wizard

Super Mentor

@Brendan Smith

Also please check if you have installed the following packages on your ambari server?

yum install krb5-server krb5-libs krb5-workstation

Specially the "krb5-workstation" or "krb5-devel" which contains the "kadmin" utility on the ambari-server host.

5 REPLIES 5

Re: API POST Error when Configuring Kerberos through wizard

Super Mentor

@Brendan Smith

When you get the above mentioned error in the ambari UI, do you see a complete stackTrace of the error in detail inside the "/var/log/ambari-server/ambari-server.log". Can you please post that error here?

Re: API POST Error when Configuring Kerberos through wizard

New Contributor

Hey there, yes the error is in there hopefully you can make more sense of it.

output.txt

Re: API POST Error when Configuring Kerberos through wizard

Super Mentor

@Brendan Smith

Also please check if you have installed the following packages on your ambari server?

yum install krb5-server krb5-libs krb5-workstation

Specially the "krb5-workstation" or "krb5-devel" which contains the "kadmin" utility on the ambari-server host.

Re: API POST Error when Configuring Kerberos through wizard

New Contributor

Shouldn't the workstations be installed as part of the "Install Kerberos Client" which is being run successfully?

I did do the install on the Ambari host and am now getting a different message would this be because the server is now on the Ambari host.

14064-kerberoserrorv2.png

Highlighted

Re: API POST Error when Configuring Kerberos through wizard

New Contributor

Ok so I updated the /etc/krb5.conf file to the same found on the KDC host and it seems to work now. I didn't see this step anywhere in the documentation and thought the wizard would install the clients.

Thanks a lot!

Don't have an account?
Coming from Hortonworks? Activate your account here