Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

About hbase-1.1.2.2.3.4.0-3485 has too many close_wait on regionserver bug

About hbase-1.1.2.2.3.4.0-3485 has too many close_wait on regionserver bug

New Contributor

I used hbase-1.1.2.2.3.4.0-3485 version .

Now I find my regionserver has too many close_wait, restart doesn’t slove it

[root@hdfs009 ~]# lsof |wc -l

35908

[root@hdfs009 ~]# lsof |grep hbase |wc -l

30690

when it grows up to 65535,regionserver will shutdown with too many open files in regionserver log.

I try to patch it with this article:

https://issues.apache.org/jira/browse/HBASE-9393

but hbase-1.1.2.2.3.4.0-3485version is too older,only newly hbase-branch in github can be patched.

[root@hdfs002 hbase-release-HDP-2.3.4.0-tag]# git apply ../HBASE-9393.v15.patch

error: patch failed: hbase-server/src/main/java/org/apache/hadoop/hbase/io/FSDataInputStreamWrapper.java:74

error: hbase-server/src/main/java/org/apache/hadoop/hbase/io/FSDataInputStreamWrapper.java: patch does not apply

error: patch failed: hbase-server/src/main/java/org/apache/hadoop/hbase/io/hfile/HFile.java:477

error: hbase-server/src/main/java/org/apache/hadoop/hbase/io/hfile/HFile.java: patch does not apply

error: patch failed: hbase-server/src/main/java/org/apache/hadoop/hbase/io/hfile/HFileBlock.java:1351

error: hbase-server/src/main/java/org/apache/hadoop/hbase/io/hfile/HFileBlock.java: patch does not apply

error: hbase-server/src/main/java/org/apache/hadoop/hbase/io/hfile/HFileReaderImpl.java: No such file or directory

I really don't want to upgrade my hdp2.3 ,please give me some help .

thanks so much.

4 REPLIES 4

Re: About hbase-1.1.2.2.3.4.0-3485 has too many close_wait on regionserver bug

Super Collaborator

The was no recent progress in HBASE-9393

The solution there is not finalized.

Re: About hbase-1.1.2.2.3.4.0-3485 has too many close_wait on regionserver bug

New Contributor

Hi,Ted ,the HBASE-9393 now can be patched avaliable,I hope our hortonworks team can provide a hortonworks version patch for this bug

Highlighted

Re: About hbase-1.1.2.2.3.4.0-3485 has too many close_wait on regionserver bug

New Contributor

I hope it can be patched as soon as possible,I wait it. I hope it can be patched

Re: About hbase-1.1.2.2.3.4.0-3485 has too many close_wait on regionserver bug

New Contributor

hbasev15patch.tar.gz this is the close wait patch,can anyone provide a hbase1.1.2 version patch,

I really appreciate it for your help

Don't have an account?
Coming from Hortonworks? Activate your account here