Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Access Impala via MSSQL Linked server ODBC

Access Impala via MSSQL Linked server ODBC

Master Collaborator

Hi,

 does anybody has an experience with a setup of MS SQL Linked server connecting to Impala via ODBC driver when Impala is configured to authenticate via LDAP?

 

The problem is that in the Linked Server config page under security tab there has to be defined a clear mapping from Local user (Users domain name in the SQL Server) vs Remote user name and password.

In the mapping when I enter the domain user name (abc\dwh) and map it to the same user and domain password, the mapping works, Impala recognize the user because validate the username and password against the Active Directory. Query runs without problem.

 

pic1.png

 

But what if I do not want to store here the dwh user's password (because after every change of the DWH user password I would have to change it here as well) and use Impersonation or even better the option of connecting under "login's current security context"?

 

pic2.png 

This does not work, queries fail with this error:

OLE DB provider "MSDASQL" for linked server "Impala" returned message "[Cloudera][ImpalaODBC] (100) Error from the Impala Thrift API: SASL(-1): generic failure: All-whitespace username.".
Msg 7303, Level 16, State 1, Line 2
Cannot initialize the data source object of OLE DB provider "MSDASQL" for linked server "Impala".

 

pic3.png

 

The same error after this change. 

 

So the conclusion is that MS SQL somehow does not send the users login and (hashed) password to the ODBC driver, and the driver just sends an empty user name (and password) to the Impala daemon.

 

Any suggestion how to resolve this issue?

 

Thanks

Tomas

 

1 REPLY 1

Re: Access Impala via MSSQL Linked server ODBC

Contributor
I have the same issue. Any fix?

Regards,
Joaquín Silva