Support Questions
Find answers, ask questions, and share your expertise
Alert: Please see the Cloudera blog for information on the Cloudera Response to CVE-2021-4428

Add Cluster on Cloudera Manager 5.2 on EC2 Instance using Classic Wizard. SSH credentials? Thanks!

Thanks in advance for the help. 


I used to create an ec2 instance and then add a cluster on CM 4 by choosing the option that wasn't "Classic Wizard." It would then ask me for my OS, Instance Type, Number of instances and Group name. The second screen would ask me for my AWS Access Key, etc. Everything would go well, but I am upgrading to 5.2 as I could never get Spark parcel to work. 


However, I do not see this option anymore on CM 5.2 and I do not know how to set up a cluster for ec2. Few questions...


1) What IP should be my host (first step of the classic wizard)? Is it the public IP of my ec2 instance or the IP that putty uses for ubuntu?


2) What are the credentials for SSH? I tried following an online tutorial, where i created a user in ubuntu, went to su visudo and made the appropriate changes (newuser ALL=(ALL:ALL) NOPASSWD: ALL..something like that). I tried using that for user, but did not work.


I tried selecting my ec2 instance ip and added a keypair file, that did not work either.


3) Do I need to download Cloudera director? I tried to download using the command sudo listed on the website, but the file was not found.


Pretty lost here so any advice is appreciated!




Are you referring to this procedure?

Cloudera Director is definitely a preferred option if you want to deploy CDH and CM on AWS. The bits can be installed from the repo, the supported OSes are in subdirectories just like for CDH. If you need assistance with setting up the repository do let us know.

Once you have Director installed, you can follow the user guide to get started. Director has its own forum in this community, feel free to post there with any questions or comments. Your feedback is greatly appreciated!
Gautam Gopalakrishnan

Thank you for the response.


1) Yes, that is the procedure I am trying to follow. However, I can get up to Step 2, #3, but screen #4 never appears for me (as it was in CM 4.7). Instead it asks me to search for a host, and then a few screens later it asks for ssh credentials (picture below). 


I have tried creating a user/password in ssh, going to visudo and making the required changes, but I can't get the authentication to work. I hvae tried many dift combinations. I have tried using the ec2 instance public IP address and using the "All hosts accept same private key" option as well.


2) I tried downloading Cloudera Director, but the sudo command provided on the cloudera director website did not work as ubuntu kept saying it could not locate the file. I am more confused on why I can't get to the setup that you are describing that asks for the AWS access keys as I do not want to run a c3.large instance. 









So I got past the SSH Credentials screen by using ubuntu as user and the key pair. The installation almost completed until I got this message: failed to receive heartbeat from agent.


I tried entering in the fdqn in the etc/hosts file, but that did not help and i have disabled firewalls. 


I am not looking to install cloudera director, but I would love if somehow the manual installation that was seen in CM 4 could be brought back.


Thanks for the help!