Support Questions
Find answers, ask questions, and share your expertise
Alert: Please see the Cloudera blog for information on the Cloudera Response to CVE-2021-4428

Adding Nifi through Ambari in Docker HDP Sandbox is failing


Hello Community,

I am trying to install Nifi on HDP Sandbox of Docker but I am running into this error here nifi-error.pdf

I am following the precise instructions as here

but to no luck.

This is the error that is starting the failure nifi-error.pdf

stderr: /var/lib/ambari-agent/data/errors-252.txt

resource_management.core.exceptions.Fail: Execution of 'tar -xf /tmp/HDF- -C /opt/HDF- >> /var/log/nifi/nifi-setup.log' returned 2. tar: This does not look like a tar archive

Anyone have any ideas of how I can fix this?



Expert Contributor

@Sree Reddy,

The file is gzipped but ambari doesn't know how to handle it. Try gzip -d /tmp/HDP- which will leave you with just the tar file without the .gz. Then try again with ambari to install.




@jwhitmore for your answer. The problem i am running into is that HDF- is empty and I am not able to figure out where to get the right HDF- and load into the HDP sandbox for Docker

Any advice would be much appreciated!

Expert Contributor

@Sree Reddy,

Can you just try again from ambari to add the service? The download that it is doing in the middle is hosted by AWS, which was down for a while on Tuesday. I just tried it and it worked perfectly, so I'm hoping you will have success this time around.


You are a life saver @jwhitmore

Totally works. Now it makes sense why it din't work.