Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Address already in use when deploying a cluster

Solved Go to solution
Highlighted

Address already in use when deploying a cluster

Contributor

I had few issues in installing (running out of space etc). So I cleared previous installs, reinstalled Ambari and trying to deploy a cluster now. Getting the following error. Possibly the cleanup didnt go through fine?

INFO 2016-04-07 09:24:28,058 DataCleaner.py:120 - Data cleanup started

INFO 2016-04-07 09:24:28,074 DataCleaner.py:122 - Data cleanup finished
ERROR 2016-04-07 09:24:28,232 main.py:268 - Failed to start ping port listener of: [Errno 98] Address already in use
INFO 2016-04-07 09:24:28,233 PingPortListener.py:61 - Ping port listener killed
ERROR 2016-04-07 09:24:28,233 main.py:309 - Fatal exception occurred:
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/ambari_agent/main.py", line 306, in <module>
    main(heartbeat_stop_callback)
  File "/usr/lib/python2.6/site-packages/ambari_agent/main.py", line
1 ACCEPTED SOLUTION

Accepted Solutions

Re: Address already in use when deploying a cluster

@Arvind Kandaswamy

On the Ambari Server, Could you try the below

netstat -nap | grep 8080

ps -ef | grep ambari

If there are some stray process running then kill them , Make sure no one is listening on 8080.

6 REPLIES 6

Re: Address already in use when deploying a cluster

@Arvind Kandaswamy

On the Ambari Server, Could you try the below

netstat -nap | grep 8080

ps -ef | grep ambari

If there are some stray process running then kill them , Make sure no one is listening on 8080.

Re: Address already in use when deploying a cluster

Contributor

nothing is listening on 8080. but i do see the following running when i did ps -ef

/usr/bin/python /usr/lib/python2 .6/site-packages/ambari_agent/AmbariAgent.py

/usr/bin/python /usr/lib/python2 .6/site-packages/ambari_agent/main.py

It appears they all have been started two days ago. Can I kill them?

Re: Address already in use when deploying a cluster

Rising Star

Yes, and restart it. Should be fine. Thanks!

Re: Address already in use when deploying a cluster

@Arvind Kandaswamy

Is this resolved?

Re: Address already in use when deploying a cluster

Rising Star

@Arvind Kandaswamy it is complaining about the ping port listener. This is not port 8080 but is defined in your /etc/ambari-agent/conf/ambari-agent.ini. It is normally port 8670. Try running netstat -tulpn | grep 8670 to see what is on that port.

Re: Address already in use when deploying a cluster

Contributor

I did kill all of the processes and started all over again. I ran into a different issue for which I created another ticket. Thankyou for your response.

Don't have an account?
Coming from Hortonworks? Activate your account here