Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

After disabling kerberos , ZKfailover not coming up.

Solved Go to solution

After disabling kerberos , ZKfailover not coming up.

Contributor

@mrizvi

@geoffery

@Ankit Singhal

log.txt After Disabling kerberos from our kerberized cluster Zkfailover is not coming up inspite of the fact Zookepeer and journal nodes are up and running. i have seen the logs.This error is realted to ssl but i am unable to figure it out. Please find attched the logs.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: After disabling kerberos , ZKfailover not coming up.

Looks like ZKFC is still trying to authenticate itself using Kerberos, could you please check if all Kerberos configurations have been removed from the Hadoop Configuration and Kerberos is disabled

ERROR client.ZooKeeperSaslClient (ZooKeeperSaslClient.java:respondToServer(323)) - SASL authentication failed using login context 'Client'.

Also could you please check if this ZNode is still available

/hadoop-ha/dshdp-rlab
5 REPLIES 5
Highlighted

Re: After disabling kerberos , ZKfailover not coming up.

Looks like ZKFC is still trying to authenticate itself using Kerberos, could you please check if all Kerberos configurations have been removed from the Hadoop Configuration and Kerberos is disabled

ERROR client.ZooKeeperSaslClient (ZooKeeperSaslClient.java:respondToServer(323)) - SASL authentication failed using login context 'Client'.

Also could you please check if this ZNode is still available

/hadoop-ha/dshdp-rlab

Re: After disabling kerberos , ZKfailover not coming up.

Contributor
@Jonas Straub

Could you please tell how and where to check all the kerberos configurations are removed or not? Also we are getting a different kind of logs now. PFA the same.log.txt

Re: After disabling kerberos , ZKfailover not coming up.

The error messages are definitely related. Zookeeper is not able to authenticate itself and it looks like its shutting down because of that.

If you go to Ambari -> HDFS Service, filter/search for "Kerberos", "Principal" and "Keytab", do the same for the actual configurations under /etc/hadoop/conf.

Re: After disabling kerberos , ZKfailover not coming up.

Super Collaborator

@Yukti Agrawal

can you try shutting down all Zookeepers and start one at a time?

Re: After disabling kerberos , ZKfailover not coming up.

Contributor

I did, but not working

Don't have an account?
Coming from Hortonworks? Activate your account here