Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
hello. I'm using on apache ambari 2.7.5.0 and hdp 3.1.4.0.
After installing kerberos on ambari, hdfs, hive, and hbase were successfully authenticated using keytab and then used services.
However, if I use yarn to run wordcount, I get an error. In the case of the file permission executing wordcount, the same was confirmed, and in the case of the user name authenticated using keytab, the same was confirmed.
When running wordcount using yarn, the same error message as when yarn node -list -all is output is displayed. Below is the error message printed by 'yarn node -list -all.'
21/07/21 14:24:03 INFO retry.RetryInvocationHandler: java.io.IOException: DestHost:destPort hadoop1:8050 , LocalHost:localPort hadoop1/192.168.22.168:0. Failed on local exception: java.io.IOException: org.apache.hadoop.security.AccessControlException: Client cannot authenticate via:[TOKEN, KERBEROS], while invoking ApplicationClientProtocolPBClientImpl.getClusterNodes over null after 24 failover attempts. Trying to failover after sleeping for 17666ms.
21/07/21 14:24:21 WARN ipc.Client: Exception encountered while connecting to the server : org.apache.hadoop.security.AccessControlException: Client cannot authenticate via:[TOKEN, KERBEROS]
i'm using a single node for ambari.
Anyone know a solution to this problem?
Created 07-23-2021 01:41 AM
I fixed this error.
1. 'yarn' user Authenticate to kerberos as yarn/[HOST_NAME]@[REALM].
2. YARN => CONFIGS => ADVANCED => Advanced container-executor => container-executor-configuration-template change the setting below
banned.users=hdfs,mapred,bin
min.user.id={{min_user_id}} 3. YARN => CONFIGS => SETTINGS
- Set 'Memory-Node' to fit my node.
- Set 'Memory-Container-Minimum Container Size' to fiy my node.
- Set 'Memory-Container-Maximum Container Size' to fiy my node.
Created 07-23-2021 01:41 AM
I fixed this error.
1. 'yarn' user Authenticate to kerberos as yarn/[HOST_NAME]@[REALM].
2. YARN => CONFIGS => ADVANCED => Advanced container-executor => container-executor-configuration-template change the setting below
banned.users=hdfs,mapred,bin
min.user.id={{min_user_id}} 3. YARN => CONFIGS => SETTINGS
- Set 'Memory-Node' to fit my node.
- Set 'Memory-Container-Minimum Container Size' to fiy my node.
- Set 'Memory-Container-Maximum Container Size' to fiy my node.